Bug 853377 - [WHQL][virtio-scsi]BSOD occurs while running job(2094) named "Plug and Play Driver Test(Certification)" on windows 2003 guest on HCK
[WHQL][virtio-scsi]BSOD occurs while running job(2094) named "Plug and Play D...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 05:55 EDT by Min Deng
Modified: 2013-11-21 18:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Do not document. Temporary regression.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:59:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SCREENSHOT (31.95 KB, image/png)
2012-08-31 05:55 EDT, Min Deng
no flags Details
anlysis (1.50 KB, application/octet-stream)
2012-09-05 05:59 EDT, Min Deng
no flags Details

  None (edit)
Description Min Deng 2012-08-31 05:55:53 EDT
Created attachment 608468 [details]
SCREENSHOT

Description of problem:
BSOD with error code F4 occurs while running job "Plug and Play Driver Test(Certification)" on win2k3-64 on HCK

Version-Release number of selected component (if applicable):
kernel-2.6.32-302.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.307.el6.x86_64
virtio-win-prewhql-0.1-34

How reproducible:
Always
Steps to Reproduce:
1.Boot up guest with the CLI
  /usr/libexec/qemu-kvm -m 2G -smp 4 -cpu cpu64-rhel6,+x2apic,family=0xf -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet0,mac=00:12:27:44:F1:c4 -uuid 27fc3530-0f10-4b6e-b1d7-09f8d7a63291 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k3-blk-scsi,server,nowait -mon chardev=111a,mode=readline -spice port=5932,disable-ticketing -vga qxl -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -bios /usr/share/seabios/bios-pm.bin -drive file=win2k3-64-scsi.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk0 -drive file=disk1.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk1 -drive file=disk2.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk2 -drive file=disk3.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk3 -drive file=disk4.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk4 -device virtio-scsi-pci,id=bus1 -device scsi-hd,bus=bus1.0,drive=scsi-disk0,id=disk,serial=test,bootindex=1 -device scsi-hd,bus=bus1.0,drive=scsi-disk1,id=disk1,serial=test1 -device scsi-hd,bus=bus1.0,drive=scsi-disk2,id=disk2,serial=test2 -device scsi-hd,bus=bus1.0,drive=scsi-disk3,id=disk3,serial=test3 -device scsi-hd,bus=bus1.0,drive=scsi-disk4,id=disk4,serial=test4

2.Submit job Plug and Play Driver Test(Certification)  for the guest on HCK
  
Actual results:
The job can pass

Expected results:
The job let guest hit BSOD with error code 0X000000F4

Additional info:

The issue can be reproduced via both SPICE and VNC
Comment 4 Min Deng 2012-09-05 05:59:43 EDT
Created attachment 609965 [details]
anlysis
Comment 6 Min Deng 2012-09-07 06:19:44 EDT
The job can passed on DTM
Comment 7 Min Deng 2012-09-14 02:19:21 EDT
(In reply to comment #6)
> The job can passed on DTM
  I tried the bug on windows 2003 64 bits via virtio-win-prewhql-0.1-35
the job can passed finally in HCK(it is newer verison).
Comment 8 Vadim Rozenfeld 2012-12-12 05:09:36 EST
(In reply to comment #7)
> (In reply to comment #6)
> > The job can passed on DTM
>   I tried the bug on windows 2003 64 bits via virtio-win-prewhql-0.1-35
> the job can passed finally in HCK(it is newer verison).

Hi Min, 
Can we close it, based on your comments #6 and #7?
Or should we keep it open, and recheck it again during HCK testing cycle?

Thank you,
Vadim.
Comment 9 Mike Cao 2012-12-12 05:46:24 EST
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > The job can passed on DTM
> >   I tried the bug on windows 2003 64 bits via virtio-win-prewhql-0.1-35
> > the job can passed finally in HCK(it is newer verison).
> 
> Hi Min, 
> Can we close it, based on your comments #6 and #7?
> Or should we keep it open, and recheck it again during HCK testing cycle?
> 
> Thank you,
> Vadim.

I refer to keep and and propose to next release .It is not good to mix hck related bug and WLk related bugs.

Best Regards,
Mike
Comment 10 dawu 2013-01-16 04:24:27 EST
Verified this bug on latest version virtio-win-prewhql-50 with steps in comment #0

CLI:

/usr/libexec/qemu-kvm -m 2G -smp 4 -cpu cpu64-rhel6,+x2apic,family=0xf -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet0,mac=00:12:27:22:78:01 -uuid 0e230e5b-5251-4894-972d-408b08a97474 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k3-blk-scsi,server,nowait -mon chardev=111a,mode=readline -spice port=5931,disable-ticketing -vga qxl -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -drive file=win2k3-64-scsi-50.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk0 -drive file=disk1.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk1 -drive file=disk2.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk2 -drive file=disk3.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk3 -drive file=disk4.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk4 -device virtio-scsi-pci,id=bus1 -device scsi-hd,bus=bus1.0,drive=scsi-disk0,id=disk,serial=test,bootindex=1 -device scsi-hd,bus=bus1.0,drive=scsi-disk1,id=disk1,serial=test1 -device scsi-hd,bus=bus1.0,drive=scsi-disk2,id=disk2,serial=test2 -device scsi-hd,bus=bus1.0,drive=scsi-disk3,id=disk3,serial=test3 -device scsi-hd,bus=bus1.0,drive=scsi-disk4,id=disk4,serial=test4 -monitor stdio -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0

Actually Results:
on version virtio-win-prewhql-50, job pass without any error.

Based on above, this issue has been fixed.

Thanks!
Best Regards,
Dawn
Comment 11 Mike Cao 2013-01-20 22:24:36 EST
Based on comment #10 .move status to VERIFIED

Since build50 over win 2013 will not shipped ,keep product to RHEL6.5.0
Comment 14 Vadim Rozenfeld 2013-10-22 04:25:38 EDT
moving to 6.6 since we still have unresolved build problem
Comment 16 errata-xmlrpc 2013-11-21 18:59:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html

Note You need to log in before you can comment on or make changes to this bug.