Bug 853386 - virt-install --graphics spice does not create the spicevmc channel
virt-install --graphics spice does not create the spicevmc channel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Giuseppe Scrivano
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 06:42 EDT by Marko Myllynen
Modified: 2016-04-26 11:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-virtinst-0.600.0-21.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:23:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-08-31 06:42:31 EDT
Description of problem:
Although virt-install(1) states that

...
   Graphics Configuration
...
       --graphics TYPE,opt1=arg1,opt2=arg2,...
         Specifies the graphical display configuration.
...
         type
             The display type. This is one of:
...
             spice

             Export the guest’s console using the Spice protocol. Spice allows
             advanced features like audio and USB device streaming, as well as
             improved graphical performance.

             Using spice graphic type will work as if those arguments were
             given:

                 --video qxl --channel spicevmc
...

The channel is not created in reality with --graphics spice:

localhost:~> virt-install --connect qemu:///system --name test-vm-1 --arch x86_64 --vcpus 2 --cpu host --ram 2048 --os-type linux --os-variant rhel6 --cdrom /tmp/test.iso --disk path=/var/lib/libvirt/images/test-vm-1,format=qcow2,cache=none,io=native,size=8 --network
network=default --graphics spice --noreboot > /dev/null 2>&1 &
[1] 1234
localhost:~> virsh --connect qemu:///system dumpxml test-vm-1 | grep -i -E '(chan|qxl|spice)'
    <graphics type='spice' port='5902' autoport='yes'/>
      <model type='qxl' vram='65536' heads='1'/>

When additionally using --channel spicevmc, the above grep command prints the channel as expected.

Version-Release number of selected component (if applicable):
RHEL 6.3 / python-virtinst-0.600.0-8.el6.noarch
Comment 5 Cui Lei 2014-05-04 22:28:07 EDT
The problem still there. virt-install --graphics spice still did not create the spicevmc channel

Version:
virt-manager-0.9.0-20.el6.x86_64
python-virtinst-0.600.0-20.el6.noarch
libvirt-0.10.2-29.el6_5.7.x86_64


Steps:
1. Execute the command like comment3:
virt-install --connect qemu:///system --name test-vm-1 --arch x86_64 --vcpus 2 --cpu host --ram 2048 --os-type linux --os-variant rhel6 --cdrom /var/lib/libvirt/images/rhel-server-i386-p2v-6.5_20131105.6-1.iso --disk path=/var/lib/libvirt/images/test-vm-1,format=qcow2,cache=none,io=native,size=8 --network network=default --graphics spice --noreboot

2. virsh dumpxml test-vm-1 | grep -i -E '(chan|qxl|spice)'
    <graphics type='spice' port='5901' autoport='yes' listen='127.0.0.1'>
      <model type='qxl' ram='65536' vram='65536' heads='1'/>

Carefully check the dumpxml, there is no spicevmc channel created.

Additional info:

When additionally using --channel spicevmc, the above grep command prints the channel as expected.

1. virt-install --connect qemu:///system --name test-vm-1 --arch x86_64 --vcpus 2 --cpu host --ram 2048 --os-type linux --os-variant rhel6 --cdrom /var/lib/libvirt/images/rhel-server-i386-p2v-6.5_20131105.6-1.iso --disk path=/var/lib/libvirt/images/test-vm-1,format=qcow2,cache=none,io=native,size=8 --network network=default --graphics spice --channel spicevmc --noreboot

2. virsh dumpxml test-vm-1 | grep -i -E '(chan|qxl|spice)'
    <channel type='spicevmc'>
      <target type='virtio' name='com.redhat.spice.0'/>
      <alias name='channel0'/>
    </channel>
    <graphics type='spice' port='5901' autoport='yes' listen='127.0.0.1'>
      <model type='qxl' ram='65536' vram='65536' heads='1'/>

So change the status from 'ON_QA' to 'ASSIGNED'
Comment 8 Cui Lei 2014-05-07 02:51:18 EDT
I can reproduce this issue as comment5.

Verified this issue with:
virt-manager-0.9.0-21.el6.x86_64
python-virtinst-0.600.0-21.el6.noarch
libvirt-0.10.2-29.el6_5.7.x86_64

1. # virt-install --connect qemu:///system --name test-vm-1 --arch x86_64 --vcpus 2 --cpu host --ram 2048 --os-type linux --os-variant rhel6 --cdrom /var/lib/libvirt/images/rhel-server-i386-p2v-6.5_20131105.6-1.iso --disk path=/var/lib/libvirt/images/test-vm-1,format=qcow2,cache=none,io=native,size=8 --network network=default --graphics spice --noreboot

2. # virsh dumpxml test-vm-1 | grep -i -E '(chan|qxl|spice)'
    <channel type='spicevmc'>
      <target type='virtio' name='com.redhat.spice.0'/>
      <alias name='channel0'/>
    </channel>
    <graphics type='spice' port='5900' autoport='yes' listen='127.0.0.1'>
      <model type='qxl' ram='65536' vram='65536' heads='1'/>

The spicevmc channel was created. So change the status from 'ON_QA' to 'VERIFIED'
Comment 9 errata-xmlrpc 2014-10-14 02:23:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1444.html

Note You need to log in before you can comment on or make changes to this bug.