This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 853399 - REGRESSION: FileDialog no longer returns the selected directory
REGRESSION: FileDialog no longer returns the selected directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
17
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 07:56 EDT by Johan Vromans
Modified: 2013-05-27 21:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: gtk2-2.24.18-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 21:03:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Program demonstrating the bug (329 bytes, text/x-python)
2012-08-31 07:56 EDT, Johan Vromans
no flags Details

  None (edit)
Description Johan Vromans 2012-08-31 07:56:38 EDT
Created attachment 608495 [details]
Program demonstrating the bug

Description of problem:

Several programs that use Gnome file and directory dialogs stopped working correctly. 

Version-Release number of selected component (if applicable):

Fedora 17 on x86_64 with all updates (the system is updated several times per week).

How reproducible:

Steps to Reproduce:
1. Run the attached python program.
2. Select a file somewhere.
3. Inspect the result dialog
  
Actual results:

For example, when HOME is /home/jv, and the file selected is /home/jv/foo/bar.txt, the results are:

path = /home/jv/foo/bar.txt
filename = bar.txt
directory = /homejv

Expected results:

path = /home/jv/foo/bar.txt
filename = bar.txt
directory = /homejv/foo

Additional info:

Since many programs seem to process the filename and directory, concatenating them if necessary, they end up with the wrong filename.
Programs that process the result of GetPath do not have problems.

The DirDialog has similar problems.

This change was introduced with an update somewhen in the first week(s) of august 2012. Before that time I never noticed anything problematic. After that time several programs started misbehaving to the point of being unusable.
Comment 1 Johan Vromans 2012-09-01 04:20:28 EDT
Changed component to gtk2. AFAIK, F17 wxWidgets is still gtk2 based.
Comment 2 Johan Vromans 2012-09-03 04:32:48 EDT
I've verified that by downgrading gtk2-2.24.11-1 to gtk2-2.24.10-2 the problems disappear.
Comment 3 Johan Vromans 2012-11-06 02:03:33 EST
Is it considered normal practice to introduce a bug that renders several application programs inoperable and then fully ignore the bug reports?
Comment 4 Rex Dieter 2013-01-02 07:39:36 EST
no it is not.

that said, you'll likely have more luck posting upstream, bugzilla.gnome.org
Comment 5 qxc 2013-01-02 08:07:22 EST
It is confirmed this bug appears with Fedora only, other distributions are not affected/work well. So why should one ask for a fix somewhere else?
Comment 6 Rex Dieter 2013-01-02 08:20:28 EST
If you want higher chances of getting some sort of response, I'd recommend you consider my advice.  it's ultimately up to you, of course.
Comment 7 Johan Vromans 2013-01-02 16:47:19 EST
I've always assumed that comments from an organisation like Red Hat / Fedora were more likely to be taken seriously than comments from individual (Gnome) users.
Comment 8 Kalev Lember 2013-05-25 19:51:32 EDT
There have been a lot of filechooser related fixes upstream. It would be great if you could check whether your issue is fixed. If not, please file a bug upstream at:
https://bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B&version=2.24.x

I am doing a gtk2 2.24.18 build for Fedora 18; can you give it a try?
Comment 9 Fedora Update System 2013-05-25 20:07:59 EDT
gtk2-2.24.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gtk2-2.24.18-1.fc18
Comment 10 Fedora Update System 2013-05-26 20:32:39 EDT
Package gtk2-2.24.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk2-2.24.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9336/gtk2-2.24.18-1.fc18
then log in and leave karma (feedback).
Comment 11 Johan Vromans 2013-05-27 05:38:55 EDT
Backported gtk2-2.24.18-1.fc18 to fc17 and verified that the problem is solved.
Thanks!
Comment 12 Fedora Update System 2013-05-27 21:03:15 EDT
gtk2-2.24.18-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.