Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 8534 - yet another problem with tar reporting "stat" errors inappropriately
yet another problem with tar reporting "stat" errors inappropriately
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-17 08:33 EST by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-18 14:55:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-01-17 08:33:28 EST
I found yet another instance in which tar fails when it can't "stat" a file
even though --ignore-failed-read is specified.  The problem is a reversed
"if" statement in src/create.c.  A patch:

--- src/create.c~	Sun Jan 16 11:14:07 2000
+++ src/create.c	Mon Jan 17 08:36:10 2000
@@ -963,9 +963,9 @@
   if (deref_stat (dereference_option, p, &current_stat) != 0)
     {
       if (ignore_failed_read_option)
-	stat_error (p);
-      else
 	stat_warn (p);
+      else
+	stat_error (p);
       return;
     }
Comment 1 Bernhard Rosenkraenzer 2000-01-18 14:55:59 EST
Fixed in 1.3.17

Note You need to log in before you can comment on or make changes to this bug.