This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 853404 - closest network mirror can't be selected
closest network mirror can't be selected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-08-31 08:29 EDT by Kamil Páral
Modified: 2013-01-09 21:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 19:52:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-08-31 08:29:59 EDT
Description of problem:
If I go to "Installation source" and select "On the network - closest mirror" and hit Back, the hub screen says "CD/DVD drive" as the source. When I go to the dialog again, "auto-detected install media" is selected again.

Version-Release number of selected component (if applicable):
F18 Alpha TC4 DVD
anaconda 18.6.4 (hey guys, don't you want to use just NN.N versions?)

How reproducible:
always
Comment 1 Kamil Páral 2012-08-31 08:41:07 EDT
When I boot from netinst, selecting closest mirror of course works (it's the default choice).

I believe this bug is closest to our Final criterion:
" The installer must be able to use all supported local and remote package source options "

With the new Anaconda UI we should consider whether we want "closest mirror" to work sooner in our development cycle and adjust criteria in that case.
Comment 2 Jesse Keating 2012-08-31 12:43:17 EDT
Depending on which media you grabbed, there was an issue with the release number used during the compose, where it would be fed into the mirror list url and not find any mirrors.  I believe this is fixed in pretc4-5 .  Can you retry with that or confirm you used that?
Comment 3 Chris Lumens 2012-08-31 13:00:12 EDT
Yeah I can reproduce this.  When you change the source in source.py, it blanks out data.method.method like it's supposed to and then calls payload.updateBaseRepo.  This first off calls payload._configureBaseRepo, which has a check for an empty data.method.method.  Finding that, it checks if /run/install/repo is mounted (which it will be, since you booted off the DVD), and sets you back to using the DVD as install source.

I don't really see a good way around this.  We can't just unmount /run/install/repo since it's in use.

I don't believe this meets any criteria, though.  You can of course still use the remote package source options if you boot the netinst, perhaps also if you boot with a repo= option.  It's simply this one unique combination that's throwing things off.
Comment 4 Jesse Keating 2012-09-06 18:37:43 EDT
Patch posted and accepted/pushed, but I'm still not completely comfortable with where it's at.  Not sure if it'll get pulled into Alpha or be post-alpha.
Comment 5 Jesse Keating 2012-10-03 19:52:24 EDT
This should be fixed in the post-alpha trees.  Please re-open if not.

Note You need to log in before you can comment on or make changes to this bug.