Bug 853406 - [abrt] gnome-doc-utils-0.20.10-2.fc17: __init__.py:577:to_pot:IOError: Unable to read file 'values/strings.xml'
[abrt] gnome-doc-utils-0.20.10-2.fc17: __init__.py:577:to_pot:IOError: Unable...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-doc-utils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:b9cf9f0d4c26ab964d6829dcafb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 08:40 EDT by Mihkel Vain
Modified: 2012-08-31 08:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-31 08:43:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (250 bytes, text/plain)
2012-08-31 08:40 EDT, Mihkel Vain
no flags Details

  None (edit)
Description Mihkel Vain 2012-08-31 08:40:25 EDT
Description of problem:
I tried to convert an xml file to po with:
xml2po -o et.po values/strings.xml


Version-Release number of selected component:
gnome-doc-utils-0.20.10-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python /usr/bin/xml2po -o et.po values/strings.xml
kernel:         3.5.2-3.fc17.x86_64

backtrace:
:__init__.py:577:to_pot:IOError: Unable to read file 'values/strings.xml'
:
:Traceback (most recent call last):
:  File "/usr/bin/xml2po", line 191, in <module>
:    main(sys.argv[1:])
:  File "/usr/bin/xml2po", line 184, in main
:    xml2po_main.to_pot(filenames)
:  File "/usr/lib/python2.7/site-packages/xml2po/__init__.py", line 577, in to_pot
:    raise IOError("Unable to read file '%s'" % xmlfile)
:IOError: Unable to read file 'values/strings.xml'
:
:Local variables in innermost frame:
:xmlfile: 'values/strings.xml'
:xmlfiles: ['values/strings.xml']
:self: <xml2po.Main object at 0x7f94f153d250>
Comment 1 Mihkel Vain 2012-08-31 08:40:27 EDT
Created attachment 608501 [details]
File: core_backtrace
Comment 2 Mihkel Vain 2012-08-31 08:43:38 EDT
Sorry. User error. I should have used xml2po -o et.po values-et/strings.xml, since there is no directory named values. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.