Bug 85344 - gimp-remote is not installed
Summary: gimp-remote is not installed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gimp   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-28 12:54 UTC by Julien Olivier
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-15 19:08:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to gimp spec to enable gimp-remote (2.12 KB, patch)
2003-08-24 00:35 UTC, Scott R. Godin
no flags Details | Diff

Description Julien Olivier 2003-02-28 12:54:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
In RedHat 8.0 and in RedHat 8.1 Beta, gimp-remote is not installed. It should be
installed and image files should be associated to "gimp-remote -n" so that GIMP
doesn't open up each time you want to open a picture.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RedHat 8.x
    

Actual Results:  There is no gimp-remote

Expected Results:  gimp-remote should be installed and "gimp-remote -n" should
be the default command to edit pictures.

Additional info:

Comment 1 dkaplan 2003-04-08 00:19:40 UTC
This bug also causes a bug in gqview, which tries to open gimp-remote when you
choose to edit in gimp.


Comment 2 Julien Olivier 2003-04-08 07:45:04 UTC
I also think that gimp-remote enables the loading of pictures through gnome-vfs.
So it's a VERY useful feature.

Comment 3 Craig Ringer 2003-06-01 09:09:48 UTC
Problem still exists in RH9. Its embarrasingly easy to fix with a small spec
file edit, but it really needs to be fixed in the basic RH distro.

Comment 4 Scott R. Godin 2003-08-24 00:35:43 UTC
Created attachment 93884 [details]
patch to gimp spec to enable gimp-remote

commented text in spec explains changes.

Comment 5 Scott R. Godin 2003-08-24 00:36:57 UTC
oh my god what I just went through getting gimp-1.2.3-16.src.rpm rebuilt with
gimp-remote enabled, you do NOT want to know. perl-PDL is broken too, so do NOT
install gimp-perl as built by the rebuilt src.rpm unless you want a world of
hurt. I'll post separately about that in another bugzilla.

I've created a patch to the gimp.spec in gimp-1.2.3-16.src.rpm, that will create
gimp-1.2.3-17.src.rpm, which rebuilds properly with all manpages in their
correct place. (another bug in the spec that I dunno how it got shipped -- it
shouldn't have built as-is) 

you can patch the spec with this, and have gimp-remote if you don't mind waiting
for the rebuild. just again, do NOT install the gimp-perl rpm as built by this
package, unless you know that perl-PDL has also been fixed

Comment 6 Matt Wilson 2003-08-24 00:50:53 UTC
right, the gimp-perl stuff is why I've not touched the package in some time...


Comment 7 Scott R. Godin 2003-08-24 01:11:23 UTC
you may want to (since this seems to have been done anyway in the release of RHL
9) simply edit the spec further to either remove or not build, the gimp-perl
package until the perl-PDL package is fixed. 

I've posted the perl-PDL bug to bugzilla as
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=102975

but at least for the time being, with this patch, people can get gimp-remote
working even if they don't grok spec files. :-)

in the above bug url I note most of the steps needed to rebuild the src rpm for
gimp, to indicate my angst and frustration with perl-PDL :> (should anyone need
to know.)

Comment 8 Matt Wilson 2003-12-15 19:08:51 UTC
gimp-remote is in Fedora Core 1



Note You need to log in before you can comment on or make changes to this bug.