Bug 853444 - The list of Base channels for an activation key in organization is not correct.
The list of Base channels for an activation key in organization is not correct.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
550
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Pavel Studeník
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2012-08-31 10:36 EDT by Dimitar Yordanov
Modified: 2013-10-01 17:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:55:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-08-31 10:36:32 EDT
Description of problem:
The list of Base channels for an activation key in organization is not correct and can cause ISE.

Version-Release number of selected component (if applicable):
Satellite [ 541 | 550 ]

How reproducible:
100%

Steps to Reproduce:

1. satellite-sync -c  rhel-x86_64-server-5  -c rhel-x86_64-server-6 --no-errata --no-kickstarts --no-packages

2. Create new organization 
    Admin -> Organizatioins

3. Give the following entitelents to the new organization.
   Management (Base)  : 10
   Do not give any entitlements for any channel.
  
4. Sign Out and Log in to the new organization

5. Create new Activatoin key in the new oraganization
    Systems -> Activation Keys -> create new key -> 

6. Choose some channel from Base Channels:

7. Continue with creating the Activation key.

Actual results:

We're sorry, but the channel could not be found.

This error may have occurred in one of three ways:

    The channel requested does not exist. This is most likely if you arrived at this page through bookmarks or some other non-hyperlink.
    You do not have permission to view this channel.
    You've found an error in our site.


Expected results:
 
Channels for wich the organization does not have entitlements should not be in the list.

Additional info:
Comment 2 Tomas Lestach 2012-09-04 04:24:24 EDT
spacewalk.git: 76511a940d5d90337736067b0cc709314eb76879
Comment 3 Tomas Lestach 2012-10-23 04:30:33 EDT
do not list custom base channel twice in the base channel combo for an activation key ...

spacewalk.git: 8fd5eff5cb03e44864c30f3a9c8ccf8891986440
Comment 6 Clifford Perry 2013-10-01 17:55:30 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.