Bug 853462 - When accessing index page without prior logging in after luci fresh start, side panel (menu for the authorized) displayed unexpectedly
Summary: When accessing index page without prior logging in after luci fresh start, si...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jan Pokorný [poki]
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-31 15:44 UTC by Jan Pokorný [poki]
Modified: 2017-03-21 11:37 UTC (History)
6 users (show)

Fixed In Version: luci-0.26.0-92.el6
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-03-21 11:37:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
happens/expected screenshot comparison (58.95 KB, image/png)
2012-08-31 15:44 UTC, Jan Pokorný [poki]
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0766 normal SHIPPED_LIVE luci bug fix and enhancement update 2017-03-21 12:47:32 UTC

Description Jan Pokorný [poki] 2012-08-31 15:44:16 UTC
Created attachment 608551 [details]
happens/expected screenshot comparison

1. luci installed+started, user logged into it + keeping it opened
   in the web browser (within active session timeframe)
2. install another version (perhaps even plain reinstall will do)
3. start the newly installed version (if not automatically)
4. try to continue in the previously opened session in the web browser

Happens:
Login form with some links normally available only when logged in
(Homebase, Manage Clusters).  Both links, when clicked, only
lead back to login form as the linked content requires authorization.

Expected:
Login form as usual (i.e., no additional links).

See attached happens/expected screenshots comparison.


Sidenote:

The other part of ungraceful handling of package update while
trying to work with luci continuously is a backtrace in luci.log.
This (probably) arises from the fact the old SSL connection is no longer
in use, something what the web browser (specifically, Firefox) does
not like either (new round of allowing certificate exception):

Exception happened during processing of request from
  ('192.168.122.1', 50932)
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/paste/httpserver.py", line 1068,
  in process_request_in_thread
    self.finish_request(request, client_address)
  File "/usr/lib64/python2.6/SocketServer.py", line 322,
  in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/lib64/python2.6/SocketServer.py", line 617,
  in __init__
    self.handle()
  File "/usr/lib/python2.6/site-packages/paste/httpserver.py", line 442,
  in handle
    BaseHTTPRequestHandler.handle(self)
  File "/usr/lib64/python2.6/BaseHTTPServer.py", line 329,
  in handle
    self.handle_one_request()
  File "/usr/lib/python2.6/site-packages/paste/httpserver.py", line 431,
  in handle_one_request
    self.raw_requestline = self.rfile.readline()
  File "/usr/lib64/python2.6/socket.py", line 450,
  in readline
    data = self._sock.recv(self._rbufsize)
Error: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert bad certificate')]

Comment 5 Jan Pokorný [poki] 2016-11-16 16:26:26 UTC
Tried hard, but cannot reproduce this bug anymore.

Comment 6 Jan Pokorný [poki] 2016-11-16 17:45:41 UTC
Huh, just managed to reproduce this, with reproducer as simple as:

1. stay at login page, perhaps came_from backlink to homebase is needed
2. restart luci
3. hit reload in the web browser

Comment 8 Jan Pokorný [poki] 2016-11-29 22:35:24 UTC
There was a bad instantiation of ClusterController.

Comment 16 errata-xmlrpc 2017-03-21 11:37:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0766.html


Note You need to log in before you can comment on or make changes to this bug.