Bug 853467 - computer freezes during shutdown or reboot
computer freezes during shutdown or reboot
Status: CLOSED DUPLICATE of bug 834245
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 12:05 EDT by Aram Agajanian
Modified: 2012-09-12 11:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 11:32:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aram Agajanian 2012-08-31 12:05:37 EDT
Description of problem:
I  have two computers using IMSM RAID with F17.  Neither has been able to shut down for a while.

Version-Release number of selected component (if applicable):
mdadm-3.2.5-4.fc17.x86_64
kernel 3.5.2-3.fc17.x86_64

How reproducible:
Happens every time

Steps to Reproduce:
1. Shutdown or Reboot

  
Actual results:
Computer freezes

Expected results:
Computer should successfully poweroff or reboot


Additional info:

The two computers are a Dell Optiplex 755 and a Dell Optiplex 960.

When I use the Alt-SysRq-O combination on the Optiplex 755, I see the following messages.  After these messages are printed out, the Alt-SysRq key combinations don't work anymore.

sd 8:0:0:0: [sdg] Synchronizing SCSI Cache
sd 8:0:0:0: [sdg] Stopping disk
sd 1:0:0:0: [sdb] Synchronizing SCSI Cache
sd 1:0:0:0: [sdb] Stopping disk
sd 0:0:0:0: [sda] Synchronizing SCSI Cache
sd 0:0:0:0: [sda] Stopping disk
pci 0000:00:1e.0: wake-up capability enabled by ACPI
 pci0000:00:wake-up capability enabled by ACPI
usb 2-2: USB disconnect, device number 2
sd 6:0:0:0: Device offlined - not ready after error recovery 
ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
sr 2:0:0:0: CDB
Get event status notification 4a 01 00 00 10 00 00 00 08 00
ata4.00: cmd a0/00:00:00:08:00/00:00:00:00:00/a0 tag 0 pio 16392 in
         res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata4.00: status { DRDY }
ata4: hard resetting link
ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
sr 3:0:0:0: CDB:
Get event status notification: 4a 01 00 00 10 00 00 00 08 00
ata3.00: cmd a0/00:00:00:80:00/00:00:00:00:00/a0 tag 0 pio 16392 in
         res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata3.00: status: { DRDY }
ata3: hard resetting link
ata4: failed to reset engine (errno=-5)
ata3: railed to reset engine (errno=-5)
ata4: softreset failed (1st FIS failed)
ata4: hard resetting link
ata3: softreset failed (1st FIS failed)
ata3: hard resetting link
ata4: failed to reset engine (errno=-5)
ata3: failed to reset engine (errno=-5)
ata4: softreset failed (1st FIS failed)
ata4: hard resetting link
ata3: softreset failed (1st FIS failed)
ata3: hard resetting link
ata4: failed re reset engine (errno=-5)
ata3: failed to reset engine (errno=-5)
ata4: softreset failed (1st FIS failed)
ata4: limiting SATA link speed to 1.5 Gbps
ata4: hard resetting link
ata3: softreset failed (1st FIS failed)
ata3: limiting SATA link speed to 1.5 Gbps
ata3: hard resetting link
ata4: failed to reset engine (errno=-5)
ata3: failed to reset engine (errno=-5)
ata4: softreset failed (device not ready)
ata4: reset failed, giving up
ata4.00: disabled
ata4: EH complete
ata3: softreset failed (device not ready)
ata3: reset failed, giving up
ata3.00: disabled
ata3: EH complete
Comment 1 Aram Agajanian 2012-09-08 00:24:59 EDT
Bug 834245 is similar to this bug.
Comment 2 Jes Sorensen 2012-09-10 05:15:22 EDT
What you're seeing here are SATA errors, there is nothing in this error
message that signals an issues in the RAID stack.

Do you have anything else from the logs that may indicate RAID errors?

My guess here is that this is a problem with the SATA driver in the kernel
you are running. I wonder if the SATA controller does something funny because
you have IMSM enabled, but I am just wondering out loud here.

I am reassigning this to the kernel, if we see anymore indications it is
mdadm related, please reassign it back to me.

Jes
Comment 3 Aram Agajanian 2012-09-12 11:32:09 EDT

*** This bug has been marked as a duplicate of bug 834245 ***

Note You need to log in before you can comment on or make changes to this bug.