Bug 853468 - internal compiler error: Illegal instruction
internal compiler error: Illegal instruction
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 12:07 EDT by Pierre Ossman
Modified: 2012-10-05 08:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 08:11:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cc3qrLnp.out (132.95 KB, application/octet-stream)
2012-08-31 12:07 EDT, Pierre Ossman
no flags Details

  None (edit)
Description Pierre Ossman 2012-08-31 12:07:45 EDT
Created attachment 608553 [details]
cc3qrLnp.out

Tried to compile the kernel SRPM (kernel-3.5.2-3.fc17.x86_64) and it failed with a compiler crash:

...
+ '[' -s .newoptions ']'
+ rm -f .newoptions
+ make ARCH=x86_64 oldnoconfig
  HOSTCC  scripts/kconfig/conf.o
scripts/kconfig/conf.c: In function 'conf':
scripts/kconfig/conf.c:414:1: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc3qrLnp.out file, please attach this to your bugreport.
make[1]: *** [scripts/kconfig/conf.o] Error 1
make: *** [oldnoconfig] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.zx0FeB (%prep)
Comment 1 Jakub Jelinek 2012-10-05 08:11:51 EDT
Can't reproduce, works just fine here.  Furthermore, Illegal instruction ICE sounds like corrupted binary or overheating issue.

Note You need to log in before you can comment on or make changes to this bug.