Bug 853480 - [abrt] cinnamon-1.5.2-6.fc17: markIfUnmarked: Process /usr/bin/cinnamon was killed by signal 11 (SIGSEGV)
[abrt] cinnamon-1.5.2-6.fc17: markIfUnmarked: Process /usr/bin/cinnamon was k...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:4a9880c2ffc375b205b3d778f7e...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 13:00 EDT by Eugene Kanter
Modified: 2012-11-29 15:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 11:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.07 KB, text/plain)
2012-08-31 13:00 EDT, Eugene Kanter
no flags Details
File: environ (1.29 KB, text/plain)
2012-08-31 13:00 EDT, Eugene Kanter
no flags Details
File: limits (1.29 KB, text/plain)
2012-08-31 13:00 EDT, Eugene Kanter
no flags Details
File: backtrace (57.64 KB, text/plain)
2012-08-31 13:00 EDT, Eugene Kanter
no flags Details
File: cgroup (130 bytes, text/plain)
2012-08-31 13:01 EDT, Eugene Kanter
no flags Details
File: maps (89.68 KB, text/plain)
2012-08-31 13:01 EDT, Eugene Kanter
no flags Details
File: dso_list (19.52 KB, text/plain)
2012-08-31 13:01 EDT, Eugene Kanter
no flags Details
File: build_ids (6.13 KB, text/plain)
2012-08-31 13:01 EDT, Eugene Kanter
no flags Details
File: var_log_messages (16.90 KB, text/plain)
2012-08-31 13:01 EDT, Eugene Kanter
no flags Details
File: open_fds (1.42 KB, text/plain)
2012-08-31 13:01 EDT, Eugene Kanter
no flags Details

  None (edit)
Description Eugene Kanter 2012-08-31 13:00:41 EDT
Description of problem:
Running Automatic Bug Reporting Tool.

Hightlight a problem, then click on Problem, Open problem data, click Forward, click on Local GNU Debugger radio button, click Forward, expand Show Log, observe that during debug information package download process the problem reporting window gets wide (by itself) well beyond screen size and cinammon crashes.

Repeated the same process in GNOME session. The windows got very wide and became blue for a while then back to normal but GNOME window manager survived.
Rerport was finally created. 

To reproduce, it is necessary to erase all debuginfo and start fresh. I only happens during debuginfo load process.

cinnamon-1.5.2-6.fc17.x86_64


Version-Release number of selected component:
cinnamon-1.5.2-6.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/bin/cinnamon
crash_function: markIfUnmarked
kernel:         3.5.2-3.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 markIfUnmarked at jsgc.h
: #2 TypedMarker at jsgcinlines.h
: #3 Mark<JSObject> at jsgcinlines.h
: #4 MarkKind at jsgcinlines.h
: #5 MarkValueRaw at jsgcinlines.h
: #6 gc_root_traversal at jsgc.cpp
: #7 js::MarkRuntime at jsgc.cpp
: #8 MarkAndSweep at jsgc.cpp
: #9 GCUntilDone at jsgc.cpp
: #10 js_GC at jsgc.cpp
Comment 1 Eugene Kanter 2012-08-31 13:00:45 EDT
Created attachment 608560 [details]
File: core_backtrace
Comment 2 Eugene Kanter 2012-08-31 13:00:50 EDT
Created attachment 608561 [details]
File: environ
Comment 3 Eugene Kanter 2012-08-31 13:00:54 EDT
Created attachment 608562 [details]
File: limits
Comment 4 Eugene Kanter 2012-08-31 13:00:59 EDT
Created attachment 608563 [details]
File: backtrace
Comment 5 Eugene Kanter 2012-08-31 13:01:03 EDT
Created attachment 608564 [details]
File: cgroup
Comment 6 Eugene Kanter 2012-08-31 13:01:08 EDT
Created attachment 608565 [details]
File: maps
Comment 7 Eugene Kanter 2012-08-31 13:01:12 EDT
Created attachment 608566 [details]
File: dso_list
Comment 8 Eugene Kanter 2012-08-31 13:01:16 EDT
Created attachment 608567 [details]
File: build_ids
Comment 9 Eugene Kanter 2012-08-31 13:01:20 EDT
Created attachment 608568 [details]
File: var_log_messages
Comment 10 Eugene Kanter 2012-08-31 13:01:24 EDT
Created attachment 608569 [details]
File: open_fds
Comment 11 leigh scott 2012-09-01 00:57:31 EDT
Have you reported the bug reporting tool as well as it's faultly?
Comment 12 leigh scott 2012-09-24 10:54:34 EDT
Is the issue still present in version 1.6.0
Comment 13 Eugene Kanter 2012-11-01 14:46:58 EDT
I'll need to delete all debug packages and simulate a crash in evolution.
Will attempt it when I get a chance.
Comment 14 Eugene Kanter 2012-11-01 16:07:33 EDT
Unable to verify because abrt-gui appears not to misbehave any more.
A test application which creates a very wide window is needed to verify cinnamon.
Comment 15 leigh scott 2012-11-28 11:08:46 EST
If you find another app that can cause the crash please reopen this report
Comment 16 Eugene Kanter 2012-11-29 15:38:07 EST
Reproduced in Fedora 18,
Automatic Bug Reporting Tool opened bug 881946

Note You need to log in before you can comment on or make changes to this bug.