Bug 853494 - livemedia-creator fails on installing fedora-logos
livemedia-creator fails on installing fedora-logos
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 14:02 EDT by D. Marlin
Modified: 2013-01-10 03:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 01:00:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file used with livemedia-creator (1.81 KB, application/octet-stream)
2012-08-31 14:02 EDT, D. Marlin
no flags Details

  None (edit)
Description D. Marlin 2012-08-31 14:02:11 EDT
Created attachment 608591 [details]
kickstart file used with livemedia-creator

Description of problem:

livemedia-creator fails on installing fedora-logos from the updates repo.  After repeated attempts on different systems, this always fails on the same package.  If I remove the updates repo from the kickstart file, the image compose completes successfully.

I have installed the fedora-logos package with no errors on an existing F17 system, so the package appears to be good.


Version-Release number of selected component (if applicable):
  lorax-17.26-1.fc17.i686
  anaconda-17.29-1.fc17.i686

How reproducible:
  consistently

Steps to Reproduce:
1.  livemedia-creator \
      --make-disk --no-virt --image-only --keep-image \
      --ks=/root/F17-x86.ks
2.
3.
  
Actual results:
--------
Installing fedora-logos-17.0.2-5.fc17.noarch (4 MB)
Fedora-related icons and pictures
anaconda 17.29 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/cmdline.py", line 114, in messageWindow
    raise RuntimeError(errtxt)
  File "/usr/lib/python2.7/site-packages/pyanaconda/yuminstall.py", line 262, in callback
RuntimeError: (Error Installing Package)
A unpack error occurred when installing the fedora-logos package.  This could indicate errors when reading the installation media.  Installation cannot continue.

losetup: /dev/loop1: detach failed: Device or resource busy
2012-08-31 12:45:38,851: Install failed
--------


Expected results:

  Package installs and the rest of the compose completes without error.


Additional info:

I used a specific fedora repo because I was seeing other errors when using these mirror lists:

  http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
  http://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
Comment 1 D. Marlin 2012-09-20 14:52:28 EDT
I think I've found the problem.  Please note that the /boot partition in the example kickstart file is 'VFAT'.  The version of fedora-logos in updates adds the following lines:

  +pushd $RPM_BUILD_ROOT/boot/grub2/themes/system/
  +ln -s background.png fireworks.png
  +popd

VFAT does not support symbolic links, so I believe this will cause the install to fail.  The original (F17 GA) version of fedora-logos did not include this symbolic link, so it installed without errors.
Comment 2 Brian Lane 2012-09-20 20:31:46 EDT
Which example kickstart? livemedia-creator's example has / and /boot on ext4. We shouldn't be using VFAT for anything other than the UEFI system partition, and that's mounted on /boot/efi/ not /boot.
Comment 3 D. Marlin 2012-09-20 21:54:03 EDT
The example kickstart file is the one attached to this BZ, and which may be used with livemedia-creator to reproduce the error.  It uses:

  part /boot --size 255 --fstype vfat --asprimary --label=boot

Some devices we install require a VFAT /boot partition (boot loader requirement).

It appears that this issue is due to a change in the fedora-logos package, and not specific to livemedia-creator, so I have moved it to that package.
Comment 4 Tom "spot" Callaway 2012-09-21 12:46:06 EDT
I suppose we'll do a cp -a instead of a symbolic link. Frickin frackin legacy filesystem trash.
Comment 5 D. Marlin 2012-09-21 12:51:52 EDT
Perhaps we could try the symbolic link, and only copy if it failed?

I'm sorry, but we're still stuck with some legacy file systems, at least for now.
Comment 6 Tom "spot" Callaway 2012-09-21 13:02:34 EDT
No, because the symlink happens during package generation time. It tries to write out the package manifest including symlinks, and fails on VFAT, but not in a fatal way (that file just doesn't get written out).
Comment 7 Fedora Update System 2012-09-21 13:50:56 EDT
fedora-logos-17.0.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-logos-17.0.3-1.fc17
Comment 8 Fedora Update System 2012-09-21 13:51:07 EDT
fedora-logos-17.0.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-logos-17.0.3-1.fc18
Comment 9 Matthew Garrett 2012-09-21 14:51:32 EDT
Not sure that changing this is a good idea - /boot has to be a POSIX filesystem, using vfat for it isn't supported.
Comment 10 Fedora Update System 2012-09-22 02:30:10 EDT
Package fedora-logos-17.0.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-logos-17.0.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14528/fedora-logos-17.0.3-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-09-27 01:00:15 EDT
fedora-logos-17.0.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.