Bug 853506 - Xen crashes on AMD processor
Xen crashes on AMD processor
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 14:38 EDT by W. Michael Petullo
Modified: 2013-02-12 04:59 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-11 16:38:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2012-08-31 14:38:08 EDT
Description of problem:
I just did a fresh install of Fedora 16 on a computer with an AMD processor. I tried to boot with Linux in Xen Dom0, but Xen crashes. Downgrading to xen-4.1.1-8.fc16.x86_64 fixed the problem.

Version-Release number of selected component (if applicable):
xen-4.1.3-1.fc16.x86_64
kernel-3.4.9-2.fc16.x86_64
I also tried Fedora 17's kernel-3.5.2-3.fc17.x86_64 with the same affect

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 16
2. Install Xen
3. Boot Linux in Xen Dom0
  
Actual results:
Xen says,

    Panic on CPU 0:
    Xen BUG at pci_amd_iommu.c:33

Expected results:
Xen should boot

Additional info:
The processor is an AMD Athlon 64 X2 Dual Core Processor 3800.
Comment 1 Michael Young 2012-08-31 18:10:40 EDT
It looks like a known xen crash, see http://lists.xen.org/archives/html/xen-devel/2012-08/msg01454.html and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=684661

Could you supply the information they request there (ie. full serial boot log with iommu=debug boot option)?
Comment 2 W. Michael Petullo 2012-11-16 11:51:54 EST
The Xen packages at http://koji.fedoraproject.org/koji/taskinfo?taskID=4694272 boot fine (after I updated some packages to their Fedora 17 counterparts).
Comment 3 Fedora End Of Life 2013-01-16 10:09:33 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Cole Robinson 2013-02-11 16:38:45 EST
Closing WONTFIX for f16, sounds like this was fixed in F17
Comment 5 Michael Young 2013-02-12 04:59:00 EST
(In reply to comment #4)
> Closing WONTFIX for f16, sounds like this was fixed in F17

Or F18. The build referred to above was a preview build of xen-4.2.1 but F17 is sticking to xen-4.1.x for released builds. F18 has xen-4.2.x .

Note You need to log in before you can comment on or make changes to this bug.