Bug 853510 - Libreport attempts to submit an empty file to RHBZ on anaconda crash
Libreport attempts to submit an empty file to RHBZ on anaconda crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-31 14:56 EDT by Tim Flink
Modified: 2012-09-05 20:52 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 20:52:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
listing of files in libreport created directory after attempting to report crash (1.43 KB, text/plain)
2012-08-31 14:56 EDT, Tim Flink
no flags Details

  None (edit)
Description Tim Flink 2012-08-31 14:56:41 EDT
Created attachment 608614 [details]
listing of files in libreport created directory after attempting to report crash

Description of problem:
When there is a crash in anaconda, libreport attempts to submit an empty file which causes the reporting process to halt with errors:

fatal: RPC failed at server. The file you are trying to attach is empty, does not exist, or you don't have permission to read it.

Version-Release number of selected component (if applicable):
libreport-2.0.12-2.fc18

How reproducible:
Every time

Steps to Reproduce:
1. Boot netinstall 
2. add updates=http://tflink.fedorapeople.org/updates/f18_traceback.img to the 
   syslinux command line to force an anaconda crash
3. Attempt to report the crash to RHBZ with libreport
  
Actual results:
Bug is filed but libreport fails part way through when attempting to attach one of the files gathered

Expected results:
Bug is properly filed against RHBZ without errors

Additional info:
Testing was done using the F18 alpha TC4 netinstall iso. I attached the contents of the libreport created directory in /tmp to this bug.
Comment 1 Tim Flink 2012-08-31 14:59:04 EDT
Proposing as blocker for Fedora 18 alpha due to violation of the following Fedora 18 alpha release criterion [1]:

The installer must be able to report failures to Bugzilla and local disk, with appropriate information included

While the bug is reported with attachments, from the users' perspective, the reporting fails and it doesn't appear as if all required files are actually attached to the destination bug.

[1] http://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria
Comment 2 Jakub Filak 2012-08-31 15:56:36 EDT
Thanks for reporting.

This bug is fixed in the following update:
https://admin.fedoraproject.org/updates/FEDORA-2012-11984/libreport-2.0.12-5.fc18,abrt-2.0.11-2.fc18

There is a trac ticket for this bug:
https://fedorahosted.org/abrt/ticket/678

Is it safe to close this bug report?
Comment 3 Tim Flink 2012-08-31 16:33:43 EDT
Jakub: thanks for the update. That will be pulled in to TC5 if/when this bug is accepted as a blocker for F18 alpha.

Please don't close this bug report yet - we are using it to track the issue in F18 alpha and generally wait until the update in question is pushed to stable and the fix has been verified on a TC or RC.

Can you edit that update as fixing this bug?
Comment 4 Adam Williamson 2012-08-31 19:06:45 EDT
+1 blocker per criterion cited in comment #1.
Comment 5 Fedora Update System 2012-09-01 06:27:35 EDT
libreport-2.0.12-5.fc18, abrt-2.0.11-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-11984/libreport-2.0.12-5.fc18,abrt-2.0.11-2.fc18
Comment 6 Adam Williamson 2012-09-05 12:50:47 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion cited in comment #1.
Comment 7 Fedora Update System 2012-09-05 20:52:17 EDT
libreport-2.0.12-5.fc18, abrt-2.0.11-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.