This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 853649 - KickstartValueError: The following problem occurred on line 3 of the kickstart file: Tried to use undefined partition pv.01 in Volume Group specification
KickstartValueError: The following problem occurred on line 3 of the kickstar...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:2fe37ae36740705d0c5fbc4de06...
: Reopened
: 853652 (view as bug list)
Depends On:
Blocks: 853416
  Show dependency treegraph
 
Reported: 2012-09-01 13:28 EDT by Jason Montleon
Modified: 2012-11-29 02:44 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 16:28:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (55 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: anaconda-tb (161.51 KB, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: environ (1014 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: type (9 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: storage.log (50.14 KB, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: version (12 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: program.log (15.97 KB, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: product (6 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: syslog (67.54 KB, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: ks.cfg (208 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: anaconda.log (1.53 KB, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: release (24 bytes, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details
File: description (1.06 KB, text/plain)
2012-09-01 13:28 EDT, Jason Montleon
no flags Details

  None (edit)
Description Jason Montleon 2012-09-01 13:28:29 EDT
Description of problem:


Version-Release number of selected component:
anaconda-18.6.4

Additional info:
libreport version: 2.0.12
cmdline:        initrd=/images/fedora-18-alpha-tc5-x86_64/initrd.img ksdevice=bootif lang= stage2=http://mini.montleon.intra/cblr/ks_mirror/fedora-18-alpha-tc5-x86_64/ kssendmac ks=http://192.168.15.14/cblr/svc/op/ks/system/s03.montleon.intra BOOT_IMAGE=/images/fedora-18-alpha-tc5-x86_64/vmlinuz BOOTIF=01-52-54-00-a0-13-33 
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64
Comment 1 Jason Montleon 2012-09-01 13:28:32 EDT
Created attachment 608961 [details]
File: ifcfg.log
Comment 2 Jason Montleon 2012-09-01 13:28:34 EDT
Created attachment 608962 [details]
File: anaconda-tb
Comment 3 Jason Montleon 2012-09-01 13:28:36 EDT
Created attachment 608963 [details]
File: environ
Comment 4 Jason Montleon 2012-09-01 13:28:37 EDT
Created attachment 608964 [details]
File: type
Comment 5 Jason Montleon 2012-09-01 13:28:40 EDT
Created attachment 608965 [details]
File: storage.log
Comment 6 Jason Montleon 2012-09-01 13:28:41 EDT
Created attachment 608966 [details]
File: version
Comment 7 Jason Montleon 2012-09-01 13:28:43 EDT
Created attachment 608967 [details]
File: program.log
Comment 8 Jason Montleon 2012-09-01 13:28:45 EDT
Created attachment 608968 [details]
File: product
Comment 9 Jason Montleon 2012-09-01 13:28:47 EDT
Created attachment 608969 [details]
File: syslog
Comment 10 Jason Montleon 2012-09-01 13:28:48 EDT
Created attachment 608970 [details]
File: hashmarkername
Comment 11 Jason Montleon 2012-09-01 13:28:50 EDT
Created attachment 608971 [details]
File: ks.cfg
Comment 12 Jason Montleon 2012-09-01 13:28:52 EDT
Created attachment 608972 [details]
File: anaconda.log
Comment 13 Jason Montleon 2012-09-01 13:28:53 EDT
Created attachment 608973 [details]
File: release
Comment 14 Jason Montleon 2012-09-01 13:28:55 EDT
Created attachment 608974 [details]
File: description
Comment 15 Chris Lumens 2012-09-01 13:31:02 EDT
part  --grow --size=100
volgroup vg00 --pesize=32768 pv.01
logvol swap  --fstype="swap" --size=2048 --name=swap --vgname=vg00
logvol /  --fstype="ext4" --grow --size=100 --name=root --vgname=vg00

Your kickstart file is incorrect.  There is no partition command that defines something with a name pv.01.
Comment 16 Jason Montleon 2012-09-01 13:33:10 EDT
This works in Fedora 17. What is the new method for configuring LVM in a kickstart?
Comment 17 Jason Montleon 2012-09-01 13:37:14 EDT
Also, that top line is not what is in my kickstart, it is actually:
part pv.01 --size=100 --grow 

Look at ks.cfg comment 11 vs. anaconda-tb comment 2.
Comment 18 Jesse Keating 2012-09-04 18:10:53 EDT
*** Bug 853652 has been marked as a duplicate of this bug. ***
Comment 19 Jason Montleon 2012-10-20 15:38:20 EDT
This says fixed in 18.8, but it is still broken, or broken again, in 18.19 (Beta TC6)
Comment 20 Adam Williamson 2012-11-22 20:20:24 EST
Jason: can you please re-test with Beta RC1 and let us know current status? Thanks!
Comment 22 Jason Montleon 2012-11-28 09:23:25 EST
This is working for me again in Fedora 18 Beta RC1. Thanks!
Comment 23 Chris Lumens 2012-11-28 16:28:19 EST
Great, thanks for re-testing.

Note You need to log in before you can comment on or make changes to this bug.