Bug 85365 - About ISDN initialisation/ISDN drivers
About ISDN initialisation/ISDN drivers
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
Jay Turner
Depends On:
Blocks: 81720
  Show dependency treegraph
Reported: 2003-02-28 11:43 EST by Horst Ebenhoeh
Modified: 2015-01-07 19:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-08-11 10:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Refresh device name in DialupDruid.py (617 bytes, patch)
2003-07-30 13:13 EDT, Frank Bergmann
no flags Details | Diff

  None (edit)
Description Horst Ebenhoeh 2003-02-28 11:43:08 EST
Description of problem:


About ISDN initialisation/ISDN drivers

I use RH since 7.1 and never had problems with my ISDN Card. Passive card 
inside: AVM A! (Fritz)IRQ 10, IO 0x300, EuroISDN (EDDS1) was always that way 
and worked fine in my Pentium II 400 - box.

In Phoebe 3 (RH 8.1) the OS loads ISDN-Modules (OK), starts isdnlog (OK), 
configures networkparameters (OK) and starts loopback interface. (OK) 
But "interface isdn0" or "isdn1" ends up with "failure". ISDN isn´t  activated 
and cannot be activated. So I cannot surf... Hope you will fix this problem. 
Thank you!!!

Beside of this Phoebe 3 ist fine. I just miss one thing: A simplier 
configuration-tool for scanners (like in Mandrake) and a list of the supported 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Ngo Than 2003-03-06 12:44:34 EST
Harald, problem is that wrong device (isdn instead ippp by sync ppp) was added
in config file.
Comment 2 Harald Hoyer 2003-03-10 09:02:12 EST
hmm, ok
Comment 4 Sami Luona 2003-04-28 10:08:42 EDT
I have same problem with RH9, what config file I should edit that I can get 
isdn work?
Comment 5 Harald Hoyer 2003-04-28 10:33:44 EDT

change from 
or vice versa

you also may try the bugfix release on:
Comment 6 Paul Bolle 2003-05-05 14:26:45 EDT
Same problems here with Red Hat Linux 9. Please note that Red Hat Linux 7.3 and Red Hat 
Linux 8.0 worked fine with teh same hardware. 
I tried the bugfix release (redhat-config-network-1.2.4-3, redhat-config-network-tui-1.2.4-3 and 
rhpl-0.99.1-1). This bugfix release lead to some new problems: 
- none of the graphical logons (e.g. Network Device Control) now seem to work 
- the 'Nickname' had to be manually set to something like 'ippp0' because otherwise a file 
'/etc/sysconfig/network-scripts/ifcfg-nickname' would be created 
- after '/usr/sbin/isdnup ippp0' a lasting connection couldn't be established. A hangup occured 
within seconds. An excerpt from 'dmesg | less': 
'ippp0: dialing 1 [number deleted]... 
isdn_net: ippp0 connected 
isdn_net: local hangup ippp0 
isdn_ppp_free: ppp_slot(-1) out of range 
ippp0: remote hangup 
ippp0: Chargesum is 0 
ippp0: Chargesum is 0 
ippp_ccp: freeing reset data structure c4bca000 
ippp, open, slot: 0, minor: 0, state: 0000 
ippp_ccp: allocated reset data structure c4bca000 
 modem hang up successfull!' 
Please let me know whether you need further information. 
Comment 7 Paul Bolle 2003-05-13 05:03:38 EDT
Well, I tested a bit further. 
'cat /var/log/messages | grep ipppd' 
learned me 
'(...) ipppd: info: no PAP secret entry for this user!' 
A quick comparison of both /etc/ppp/pap-secrets and /etc/ppp/chap-secrets on Psyche and 
Shrike learned me: 
Psyche /etc/ppp/pap-secrets: 
# Secrets for authentication using PAP  
# client	server	secret			IP addresses 
####### redhat-config-network will overwrite this part!!! (begin) ########## 
"isp-username" 	* 	"isp-password" 
####### redhat-config-network will overwrite this part!!! (end) ############ 
Shrike /etc/ppp/pap-secrets: 
# Secrets for authentication using CHAP 
# client	server	secret			IP addresses 
####### redhat-config-network will overwrite this part!!! (begin) ########## 
"firstname" 	"ippp1" 	"lastname" 
"firstname" 	"ippp1" 	"None" 
"isp-username" 	"ippp0" 	"None" 
####### redhat-config-network will overwrite this part!!! (end) ############ 
(You see that I tried a few different setups, but I always enterd my ips-username and 
isp-password! /etc/ppp/chap-secrets is identical.) 
Could this be causing all this? 
Comment 8 Dietmar Musiol 2003-06-17 02:31:22 EDT
Still have the same problem to activate my Fritz card, change device from ippp0 
to isdn0 or vice versa doesn´t help
Comment 9 Frank Bergmann 2003-07-30 13:13:52 EDT
Created attachment 93263 [details]
Refresh device name in DialupDruid.py

When creating a new device for ISDN the device name must be updated regarding
to the setting of EncapMode (syncppp or rawip).
The patch refreshes the filename (ipppX or isdnX) after setting the EncapMode.
Comment 10 Harald Hoyer 2003-07-31 05:56:46 EDT
Frank, you win the price! Thx a lot!
Comment 11 Harald Hoyer 2003-08-11 10:10:19 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.