Bug 85366 - Installer removes locale information for non-installed languages
Installer removes locale information for non-installed languages
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-28 11:55 EST by vigna
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-09 17:38:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vigna 2003-02-28 11:55:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
During the installation of Red Hat 8, the installer does not install from
glibc-commons locales that are not chosen for installation. This is wrong, as
many software component (e.g., gettext) require the local to be present to
behave correctly.

In my case, my web server translates pages in Italian using gettext. However, on
a stock Red Hat installation gettext will refuse to do any translation because I
do not install the Italian language.

This choice is IMHO a bug. A server may serve pages translated with gettext in
zillions of languages, but usually no translations for applications will be
installed.

The solution is simply to do an rpm -Uvh --force
glibc-common_2.2.93-5_i38686.rpm. This reinstalls the local stuff in complete form.

It took me weeks to understand this, as gettext does not do *ANY* logging or
report *ANY* error message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 8.0 without additional languages.
2. Create a translation file for, say, Italian.
3. Try to get translations with the gettext command.
    

Additional info:
Comment 1 Jakub Jelinek 2003-03-09 17:38:05 EST
It doesn't make any sense to waste lots of megabytes of disk space for locales
nobody will ever use. If you need Italian, you should install support for
Italian.
Comment 2 vigna 2003-03-09 19:29:52 EST
The support cannot be "installed", as it is already in a package that appears to
be installed, but is not really installed (at least not completely). If there
was a package named "locale-it", I would have installed it *immediately*. The
problem is that to install the locale I had to reinstall glibc-commons, which is
not *exactly* natural.

Note You need to log in before you can comment on or make changes to this bug.