Bug 853669 - Extreme slow network in Windows 7 KVM guest using bridge mode
Extreme slow network in Windows 7 KVM guest using bridge mode
Status: CLOSED DUPLICATE of bug 855640
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-01 20:57 EDT by Arnold Wang
Modified: 2013-01-09 07:07 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 07:02:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnold Wang 2012-09-01 20:57:24 EDT
Description of problem:
I upgraded my machine from Fedora 16 to Fedora 17 recently and the virtual NIC is changed to macvtap. The machine boots fine, however the network speed in the guest dropped so much that it's almost unusable. 
BTW, I'm using bridge mode and virtio in the guest.  

Version-Release number of selected component (if applicable):
[root@mars tmp]# uname -a
Linux mars.astro.net 3.5.2-3.fc17.x86_64 #1 SMP Tue Aug 21 19:06:52 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@mars tmp]# rpm -qa | grep kvm
libvirt-daemon-kvm-0.9.11.4-3.fc17.x86_64
qemu-kvm-1.0.1-1.fc17.x86_64


How reproducible:
The problem is persistent.

Steps to Reproduce:
1. Start the virtual machine.
2. Try to download a file from Internet
3. Try to download the same file from host machine
  
Actual results:
The download speed from the guest is extremely slow compares to the speed from host.

Expected results:
I expect to see roughly same result from both guest and host machine.

Additional info:
--- qemu log ---
2012-09-02 00:03:04.794+0000: starting up
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=s
pice /usr/bin/qemu-kvm -S -M pc-0.14 -cpu core2duo,+lahf_lm,+rdtscp,+aes,+popcnt
,+x2apic,+sse4.2,+sse4.1,+xtpr,+cx16,+tm2,+est,+vmx,+ds_cpl,+pbe,+tm,+ht,+ss,+ac
pi,+ds -enable-kvm -m 4096 -smp 2,sockets=2,cores=1,threads=1 -name Windows7 -uu
id fb69f36c-5211-cbe6-71e9-0fa82942ff97 -nodefconfig -nodefaults -chardev socket
,id=charmonitor,path=/var/lib/libvirt/qemu/Windows7.monitor,server,nowait -mon c
hardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-shutdown -dev
ice virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -device ich9-usb-ehci
1,id=usb,bus=pci.0,addr=0x8.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport
=0,bus=pci.0,multifunction=on,addr=0x8 -device ich9-usb-uhci2,masterbus=usb.0,fi
rstport=2,bus=pci.0,addr=0x8.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstpor
t=4,bus=pci.0,addr=0x8.0x2 -drive file=/var/lib/libvirt/images/Windows7.img,if=n
one,id=drive-virtio-disk0,format=raw,cache=none -device virtio-blk-pci,scsi=off,
bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev 
tap,fd=21,id=hostnet0,vhost=on,vhostfd=22 -device virtio-net-pci,netdev=hostnet0
,id=net0,mac=52:54:00:2c:7c:d2,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -d
evice isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel
0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchan
nel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice por
t=5900,addr=127.0.0.1,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_s
ize=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,i
d=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pc
i.0,addr=0x7
char device redirected to /dev/pts/0
do_spice_init: starting 0.10.1
spice_server_add_interface: SPICE_INTERFACE_MIGRATION
spice_server_add_interface: SPICE_INTERFACE_KEYBOARD
spice_server_add_interface: SPICE_INTERFACE_MOUSE
spice_server_add_interface: SPICE_INTERFACE_QXL
red_worker_main: begin
display_channel_create: create display channel
cursor_channel_create: create cursor channel
*** EHCI support is under development ***
spice_server_add_interface: SPICE_INTERFACE_PLAYBACK
spice_server_add_interface: SPICE_INTERFACE_RECORD
reds_handle_auth_mechanism: Auth method: 1
reds_handle_main_link: 
reds_disconnect: 
reds_show_new_channel: channel 1:0, connected successfully, over Non Secure link
main_channel_link: add main channel client
reds_handle_main_link: NEW Client 0x7f25b6ee5960 mcc 0x7f25b6ee4f80 connect-id 1
804289383
main_channel_handle_parsed: net test: invalid values, latency 0 roundtrip 282. a
ssuming highbandwidth
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 6:0, connected successfully, over Non Secure link
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 5:0, connected successfully, over Non Secure link
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 2:0, connected successfully, over Non Secure link
red_dispatcher_set_display_peer: 
handle_dev_display_connect: connect
handle_new_display_channel: add display channel client
reds_handle_auth_mechanism: Auth method: 1
handle_new_display_channel: New display (client 0x7f25b6ee5960) dcc 0x7f259c06a3
f0 stream 0x7f25b6e88260
handle_new_display_channel: jpeg disabled
handle_new_display_channel: zlib-over-glz disabled
listen_to_new_client_channel: NEW ID = 0
reds_show_new_channel: channel 4:0, connected successfully, over Non Secure link
red_dispatcher_set_cursor_peer: 
display_channel_client_wait_for_init: creating encoder with id == 0
handle_dev_cursor_connect: cursor connect
red_connect_cursor: add cursor channel client
listen_to_new_client_channel: NEW ID = 0
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 3:0, connected successfully, over Non Secure link
inputs_connect: inputs channel client create
spice_server_add_interface: SPICE_INTERFACE_TABLET
handle_dev_set_mouse_mode: mouse mode 2
spice_server_char_device_add_interface: CHAR_DEVICE vdagent
main_channel_handle_parsed: agent start
spice_server_char_device_remove_interface: remove CHAR_DEVICE vdagent
handle_dev_stop: stop
qemu: terminating on signal 15 from pid 798
2012-09-02 00:10:05.121+0000: shutting down
2012-09-02 00:27:58.535+0000: starting up
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=s
pice /usr/bin/qemu-kvm -S -M pc-0.14 -cpu core2duo,+lahf_lm,+rdtscp,+aes,+popcnt
,+x2apic,+sse4.2,+sse4.1,+xtpr,+cx16,+tm2,+est,+vmx,+ds_cpl,+pbe,+tm,+ht,+ss,+ac
pi,+ds -enable-kvm -m 4096 -smp 2,sockets=2,cores=1,threads=1 -name Windows7 -uu
id fb69f36c-5211-cbe6-71e9-0fa82942ff97 -nodefconfig -nodefaults -chardev socket
,id=charmonitor,path=/var/lib/libvirt/qemu/Windows7.monitor,server,nowait -mon c
hardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-shutdown -dev
ice virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -device ich9-usb-ehci
1,id=usb,bus=pci.0,addr=0x8.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport
=0,bus=pci.0,multifunction=on,addr=0x8 -device ich9-usb-uhci2,masterbus=usb.0,fi
rstport=2,bus=pci.0,addr=0x8.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstpor
t=4,bus=pci.0,addr=0x8.0x2 -drive file=/var/lib/libvirt/images/Windows7.img,if=n
one,id=drive-virtio-disk0,format=raw,cache=none -device virtio-blk-pci,scsi=off,
bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev 
tap,fd=21,id=hostnet0,vhost=on,vhostfd=22 -device virtio-net-pci,netdev=hostnet0
,id=net0,mac=52:54:00:2c:7c:d2,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -d
evice isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel
0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchan
nel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice por
t=5900,addr=127.0.0.1,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_s
ize=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,i
d=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pc
i.0,addr=0x7
char device redirected to /dev/pts/0
do_spice_init: starting 0.10.1
spice_server_add_interface: SPICE_INTERFACE_MIGRATION
spice_server_add_interface: SPICE_INTERFACE_KEYBOARD
spice_server_add_interface: SPICE_INTERFACE_MOUSE
spice_server_add_interface: SPICE_INTERFACE_QXL
red_worker_main: begin
display_channel_create: create display channel
cursor_channel_create: create cursor channel
*** EHCI support is under development ***
spice_server_add_interface: SPICE_INTERFACE_PLAYBACK
spice_server_add_interface: SPICE_INTERFACE_RECORD
reds_handle_auth_mechanism: Auth method: 1
reds_handle_main_link: 
reds_disconnect: 
reds_show_new_channel: channel 1:0, connected successfully, over Non Secure link
main_channel_link: add main channel client
reds_handle_main_link: NEW Client 0x7f966de05570 mcc 0x7f966de055e0 connect-id 1
804289383
main_channel_handle_parsed: net test: latency 0.165000 ms, bitrate 62060606060 b
ps (59185.606060 Mbps)
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 6:0, connected successfully, over Non Secure link
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 5:0, connected successfully, over Non Secure link
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 4:0, connected successfully, over Non Secure link
red_dispatcher_set_cursor_peer: 
handle_dev_cursor_connect: cursor connect
red_connect_cursor: add cursor channel client
listen_to_new_client_channel: NEW ID = 0
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 2:0, connected successfully, over Non Secure link
red_dispatcher_set_display_peer: 
handle_dev_display_connect: connect
handle_new_display_channel: add display channel client
handle_new_display_channel: New display (client 0x7f966de05570) dcc 0x7f954006d4
f0 stream 0x7f966de04a80
handle_new_display_channel: jpeg disabled
handle_new_display_channel: zlib-over-glz disabled
listen_to_new_client_channel: NEW ID = 0
display_channel_client_wait_for_init: creating encoder with id == 0
reds_handle_auth_mechanism: Auth method: 1
reds_show_new_channel: channel 3:0, connected successfully, over Non Secure link
inputs_connect: inputs channel client create
spice_server_add_interface: SPICE_INTERFACE_TABLET
handle_dev_set_mouse_mode: mouse mode 2
spice_server_char_device_add_interface: CHAR_DEVICE vdagent
main_channel_handle_parsed: agent start
[root@mars qemu]#
Comment 1 Arnold Wang 2012-09-01 21:06:10 EDT
I forgot to mention another strange problem, not sure whether it has the same cause or not. It doesn't appear that the guest and host can communicate to each other, tried PING and SSH so far, even though the guest can communicate to other hosts in the network, just at very slow speed.
Comment 2 Richard Davies 2012-09-09 10:11:46 EDT
Bug 855640 may be the same?
Comment 3 Paolo Bonzini 2012-09-11 07:02:58 EDT

*** This bug has been marked as a duplicate of bug 855640 ***

Note You need to log in before you can comment on or make changes to this bug.