Bug 853678 - input method doesn't turn back to XKB engines in xterm.
input method doesn't turn back to XKB engines in xterm.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 01:43 EDT by sangu
Modified: 2012-09-08 22:13 EDT (History)
7 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-3.5.91-1.fc18.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-08 22:13:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2012-09-02 01:43:48 EDT
Description of problem:
input method  doesn't change in xterm

Version-Release number of selected component (if applicable):
1.4.99.20120822-1.fc18.x86_64


How reproducible:
always

Steps to Reproduce:
1. open xterm ( XMODIFIERS=@im=ibus xterm )
2. ctrl + space
3.
  
Actual results:


Expected results:


Additional info:
xterm-278-2.fc18.x86_64
ibus-hangul-1.4.1-5.fc18.x86_64
Comment 1 fujiwara 2012-09-03 00:23:29 EDT
(In reply to comment #0)
> Steps to Reproduce:
> 1. open xterm ( XMODIFIERS=@im=ibus xterm )
> 2. ctrl + space
> 3.

I cannot reproduce your problem after XMODIFIERS=@im=ibus is exported.
Comment 2 sangu 2012-09-03 00:35:28 EDT
current state
1. Open xterm
2. Input some char (rk)
가
3. ctrl+space (switch input method)
4 .Input some char (rk)
가

No Change, Only Hangul
Comment 3 fujiwara 2012-09-03 04:12:36 EDT
OK, I understood.
gnome-settings-daemon can switch to ibus non-xkb engines but cannot switch to ibus xkb engines in X11 because 'gtk-im-context-simple' is not used in X11.
I'd think it's better for gnome-settings-daemon to always use ibus instead of gtk-im-context-simple.
Comment 4 Rui Matos 2012-09-03 04:53:14 EDT
Should be fixed when these patches land upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=680313
Comment 5 fujiwara 2012-09-04 22:06:37 EDT
(In reply to comment #4)
> Should be fixed when these patches land upstream:
> 
> https://bugzilla.gnome.org/show_bug.cgi?id=680313

I confirmed the fix resolves this problem.

Note You need to log in before you can comment on or make changes to this bug.