This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 8537 - sysctl -p instead of sysctl -n in /etc/rc.d/rc.sysinit line 49
sysctl -p instead of sysctl -n in /etc/rc.d/rc.sysinit line 49
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-17 09:19 EST by marek
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-17 10:03:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description marek 2000-01-17 09:19:44 EST
In initscripts-4.80.3-i386.rpm package in /etc/rc.d/rc.sysinit
file in line 49 there is sysctl command with an unsuported -p
parameter (should be sysctl -n /etc/sysctl.conf instead)
Comment 1 Bill Nottingham 2000-01-17 10:03:59 EST
Um, the sysctl I have supports the -p option, and
that's what used to read commands from a file.

[notting@bobby:~ ]$ sysctl -?
usage:  sysctl [-n] variable ...
        sysctl [-n] -w variable=value ...
        sysctl [-n] -a
        sysctl [-n] -p <file>   (default /etc/sysctl.conf)
        sysctl [-n] -A

[notting@bobby:~/prog/initscripts ]$ rpm -qf /sbin/sysctl
procps-2.0.6-1

Perhaps you have a different sysctl binary/older procps?
It looks like the the -p setting was added in procps-2.0.4;
I'll fix the dependencies on initscripts so it requires at
least that version.

Note You need to log in before you can comment on or make changes to this bug.