Bug 853700 - ovirt-engine-backend [TEXT]: power management test fails and even log shows exact error from vdsm which is incorrect for UI
ovirt-engine-backend [TEXT]: power management test fails and even log shows e...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Barak
Oded Ramraz
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 04:51 EDT by Dafna Ron
Modified: 2016-02-10 14:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-02 05:45:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (490.86 KB, application/x-gzip)
2012-09-02 04:51 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-02 04:51:02 EDT
Created attachment 609026 [details]
logs

Description of problem:

when power management test fails we show the following error in event log: 

Power Management test failed for Host gold-vdsc.Failed: You have to enter plug number Please use '-h' for usage 

this is the error that vdsm is showing: 

secure=yes out  err Failed: You have to enter plug number
Please use '-h' for usage

Version-Release number of selected component (if applicable):

si16

How reproducible:

100%

Steps to Reproduce:
1. enter wrong configuration for power management on one of the hosts
2.
3.
  
Actual results:

we are getting this error: 

Power Management test failed for Host gold-vdsc.Failed: You have to enter plug number Please use '-h' for usage 

Expected results:

since user cannot type --help in UI we need to change the even log alert. 

Additional info:

backend: 

2012-09-02 11:40:06,026 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp-/127.0.0.1:8009-10) [4d20f907] FINISH, FenceVdsVDSCommand, return: Test Failed, Host Status is: unknown. The fence-agent script reported the following error: Unable to connect/login to fencing device


vdsm:

secure=yes out  err Failed: You have to enter plug number
Please use '-h' for usage
Comment 1 Itamar Heim 2012-09-02 05:45:10 EDT
we are not going to manipulate the output of the fence script

Note You need to log in before you can comment on or make changes to this bug.