Bug 853788 - anaconda (text mode) set root password appears to not to work
anaconda (text mode) set root password appears to not to work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker F18Alphappc
  Show dependency treegraph
 
Reported: 2012-09-02 16:29 EDT by Reartes Guillermo
Modified: 2013-01-09 21:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:53:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2012-09-02 16:29:45 EDT
Description of problem:

Installing in text mode, the root password function does not work. 
Tried two times with root01/root01 and one with pepepe/pepepe.
It anaconda (text mode) appears to have accepted the password.
It is not possible to log in to the installed system.

Version-Release number of selected component (if applicable):
f18 tc5 dvd

How reproducible:
always

Steps to Reproduce:
1. boot in text mode
2. set root password
3. no login after reboot
  
Expected results:
be able to se the root password

Additional info:
Comment 1 David Aquilina 2012-09-04 15:51:11 EDT
Anaconda looks like it's locking the root account by default. If you look at /root/anaconda-ks.cfg, the line reads: 

rootpw --lock --plaintext [plaintext root password]

Seen on ppc64 with anaconda 18.6.5 as well. Raising prio/sev to 'high' since ppc typically doesn't have graphics hardware.
Comment 2 Jesse Keating 2012-09-04 17:29:17 EDT
Problem located, patch posted.
Comment 3 Adam Williamson 2012-09-05 14:30:23 EDT
Proposing as Alpha blocker per criterion "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles" - if the root password isn't set you can't log in.
Comment 4 Adam Williamson 2012-09-05 14:49:49 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion cited in comment #3.
Comment 5 Kamil Páral 2012-09-07 05:03:45 EDT
Still broken in Alpha TC6.
Comment 6 Jesse Keating 2012-09-07 15:01:46 EDT
Pushed to master and picked to f18-alpha-branch.
Comment 7 Fedora Update System 2012-09-07 16:17:21 EDT
anaconda-18.6.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.6-1.fc18
Comment 8 Fedora Update System 2012-09-08 15:25:52 EDT
Package anaconda-18.6.6-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.6-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13611/anaconda-18.6.6-1.fc18
then log in and leave karma (feedback).
Comment 9 Reartes Guillermo 2012-09-10 20:59:50 EDT
Tried with f18 pretc7-2 netinst (anaconda v18.6.6) and it worked.
The root password set in the text mode installed worked after install.
Comment 10 Kamil Páral 2012-09-11 08:08:20 EDT
This is fixed in F18 Alpha RC2, root password is set.
Comment 11 Adam Williamson 2012-09-17 18:53:06 EDT
18.6.7 went stable, so closing this.
Comment 12 Fedora Update System 2012-09-17 19:57:50 EDT
anaconda-18.6.6-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.