Bug 853852 - SELinux Boolean for NFS failed to prevent nfs client access
SELinux Boolean for NFS failed to prevent nfs client access
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.2
i686 Linux
unspecified Severity high
: rc
: ---
Assigned To: Miroslav Grepl
Michal Trunecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 03:11 EDT by Irwan
Modified: 2014-09-30 19:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-168.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:28:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Irwan 2012-09-03 03:11:26 EDT
Description of problem:
Selinux failed to block access to nfs request

Version-Release number of selected component (if applicable):
1.2.3

How reproducible:
Always

Steps to Reproduce:
1. setsebool -P nfs_export_all_rw off
2. mkdir /myshare
3. chmod 777 /myshare
4. Add "/myshare 192.168.2.0/24(rw,sync)" to /etc/exports
5. exportfs -rv

   On client side:
6. mkdir /myshare
7. mount.nfs nfsserver:/myshare /myshare
8. 
  
Actual results:
Client can mount the nfs share and read/write files.

Expected results:
At this point, client is expected to NOT be able to mount and read/write files because of SELINUX booleans set in step 1.

Additional info:
Comment 2 Daniel Walsh 2012-10-08 15:13:33 EDT
Yes this boolean will not block nfs access since nfs server runs as a kernel process.

The boolean(s) should probably just be removed.
Comment 3 Miroslav Grepl 2012-10-09 04:24:46 EDT
What does

# rpm -q selinux-policy
Comment 4 Miroslav Grepl 2012-10-09 13:58:48 EDT
We have this boolean no longer in the latest policy.
Comment 9 errata-xmlrpc 2013-02-21 03:28:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.