Bug 853867 - bkr.labcontroller.message_bus requires /etc/beaker/labcontroller.conf
bkr.labcontroller.message_bus requires /etc/beaker/labcontroller.conf
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Raymond Mancy
ImplementationQuality
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 03:46 EDT by Raymond Mancy
Modified: 2015-05-03 22:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-20 01:25:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2012-09-03 03:46:21 EDT
Description of problem:

Cannot start lab controller processes in devel env because
message_bus tried to load default conf file

Version-Release number of selected component (if applicable):
0.9

How reproducible:
All the time

Steps to Reproduce:
1.cd Labcontroller/procy/src
2. PYTHONPATH=:.:./../Common python bkr/labcontroller/watchdog.py --foreground --config=../labcontroller.conf
3.
  
Actual results:
packages is being added to sys.path
  __import__('pkg_resources').declare_namespace(__name__)
Traceback (most recent call last):
  File "bkr/labcontroller/watchdog.py", line 20, in <module>
    from bkr.labcontroller.message_bus import LabBeakerBus
  File "/home/rmancy/dev/beaker/LabController/proxy/src/bkr/labcontroller/message_bus.py", line 22, in <module>
    conf = get_conf()
  File "/home/rmancy/dev/beaker/LabController/proxy/src/bkr/labcontroller/config.py", line 22, in get_conf
    load_conf()
  File "/home/rmancy/dev/beaker/LabController/proxy/src/bkr/labcontroller/config.py", line 16, in load_conf
    _conf.load_from_file(conf_file)
  File "/usr/lib/python2.6/site-packages/kobo/conf.py", line 117, in load_from_file
    fo = open(file_name, "r")
IOError: [Errno 2] No such file or directory: '/etc/beaker/labcontroller.conf'


Expected results:

watchdog should run 

Additional info:
Comment 1 Nick Coghlan 2012-10-17 00:35:24 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 2 Dan Callaghan 2012-10-25 00:22:29 EDT
It would be good to fix this. We need to make sure we don't read any config at global scope (message_bus.py is doing that, which is why it breaks).
Comment 4 Dan Callaghan 2013-07-18 20:55:11 EDT
The bkr.labcontroller.message_bus module still exists, and still has this problem, but it's not used anywhere... is there any reason we should keep it?

Note You need to log in before you can comment on or make changes to this bug.