Bug 853875 - oops in ext4_ext_remove_space
oops in ext4_ext_remove_space
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
: 852724 853589 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 04:09 EDT by Panos Kavalagios
Modified: 2012-09-10 13:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 13:29:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel stack trace (4.76 KB, text/plain)
2012-09-03 04:09 EDT, Panos Kavalagios
no flags Details

  None (edit)
Description Panos Kavalagios 2012-09-03 04:09:31 EDT
Created attachment 609292 [details]
Kernel stack trace

Description of problem: Kernel exception when a scheduled back-up command with tar was issued on Sunday 00:00.


Version-Release number of selected component (if applicable):kernel-3.5.2-3.fc17.x86_64


How reproducible: Run a schedueld tar.


Steps to Reproduce:
1. From crontab:
0 0 * * 0               /usr/local/sbin/getbackup
2. And getbackup script runs a:
tar zcf $BACKUP_ROOT/$backupfile.tgz $backupname
for various system directories

  
Actual results: The back-up failed.


Expected results: The back-up should have finished successfully.


Additional info: In the attached file kernel-stack-trace.txt is the message.
Comment 1 Dave Jones 2012-09-06 14:04:20 EDT
*** Bug 853589 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2012-09-06 14:07:29 EDT
*** Bug 852724 has been marked as a duplicate of this bug. ***
Comment 3 Lukáš Czerner 2012-09-10 12:10:14 EDT
I believe this has been fixed upstream with 

89a4e48f8479f8145eca9698f39fe188c982212f ext4: fix kernel BUG on large-scale rm -rf commands

Thanks
-Lukas
Comment 4 Josh Boyer 2012-09-10 13:29:37 EDT
(In reply to comment #3)
> I believe this has been fixed upstream with 
> 
> 89a4e48f8479f8145eca9698f39fe188c982212f ext4: fix kernel BUG on large-scale
> rm -rf commands

That commit was backported and added to the 3.5.3 stable release.  F17 is on 3.5.3 now in stable updates and thus should be fixed.

Thanks Lukas!

Note You need to log in before you can comment on or make changes to this bug.