Bug 853880 - Mailman : Cannot accept or reject moderated mail. loop on https://xxx.xx/mailman/admindb/mylist
Mailman : Cannot accept or reject moderated mail. loop on https://xxx.xx/mai...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 04:35 EDT by Pierre Blavy
Modified: 2012-09-26 05:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 04:56:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The way I accept or reject mails (101.56 KB, image/png)
2012-09-04 04:58 EDT, Pierre Blavy
no flags Details

  None (edit)
Description Pierre Blavy 2012-09-03 04:35:02 EDT
Description of problem:
When I try to accept or reject mails on mailman web interface (
https://xxx.xx/mailman/admindb/mylist) by choosing the good option and validating the web form, the same page is displayed again. My changes (accepted or rejected mails) are not taken into account.

Version-Release number of selected component (if applicable):
latest stable mailman 3 sept 2012

How reproducible: always


Steps to Reproduce:
1. Install mailman and postfix (the full procedure is here : https://bugzilla.redhat.com/show_bug.cgi?id=849418)
2. Disable selinux
3. Create a list
4. Post a list from a not suscribed user (e.g. a yopmail.com adress).
5. Wait until you recive a mail that invite you to moderate the list
6. connect to https://xxx.xx/mailman/admindb/mylist
7. accept or reject mails
  
Actual results:
The page  https://xxx.xx/mailman/admindb/mylist is displayed in loop.


Expected results:
Acecpt or reject mail should respectively accept or reject mail

Additional info:
/var/log/mailman/error is empty
Comment 1 Jan Kaluža 2012-09-04 03:19:48 EDT
It works for me as expected here. Can you please describe the way how you "accept or reject mails"? Do you choose the accept option below "Action to take on all these held messages:" label?

Or maybe you're choosing "Accepts" below "Add <mail> to one of these sender filters:" checkbox, but you do not check this checkbox.
Comment 2 Pierre Blavy 2012-09-04 04:58:24 EDT
Created attachment 609601 [details]
The way I accept or reject mails

The way I accept or reject mails
- 0 goto https://xxx.xx/mailman/admindb/niac
- 1 select accept or reject
- 2 click on submit
(my GUI is in french, sory)

This is also the page that loops.
Comment 3 Jan Kaluža 2012-09-04 07:34:15 EDT
Hm, that's the same way as I do it here. Does it happen for all your lists? Do you have some special configuration applied?

If I click on submit here, I see the table of the first user to disappear and the messages sent by that user are sent to list. I even tried it in French. I will play with it a bit and try to reproduce it, but I'm not sure what's causing that so far...
Comment 4 Pierre Blavy 2012-09-26 04:56:15 EDT
The bug did not happen to newly created lists.

This problem is indeed specific to my machine. After searching, there was something wrong in the way I've created/save and managed my old list which is not a mailman bug.

For information, I've found a workaround : save delete and restore the list with the following stricpt makes it magickaly work again.

In fact mailman store data in a lot of different places with differents rights and without a clear homogenous and easy to use interface to save/restore lists, which makes things confuse. Adding list_save list_load  list_save_all, list_load_all scripts to binary will be a good idea, and storing all information in a clear simple folder hierarchy will be a better one.


Anyway Thank you very much for your help.




--- save and restore script ---
#!/bin/sh

function savelist {
LIST=$1
OUT=$2

/usr/lib/mailman/bin/config_list  -o $OUT/$LIST.conf $LIST;
/usr/lib/mailman/bin/list_members -o $OUT/$LIST-regular.txt -r $LIST;
/usr/lib/mailman/bin/list_members -o $OUT/$LIST-digest.txt  -d $LIST;

#archives
cd /var/lib/mailman/archives/private;
tar czf $OUT/$LIST-archive.tgz $LIST;
tar czf $OUT/$LIST-mbox-archive.tgz $LIST.mbox;
}

function loadlist {
LIST=$1
IN=$2
MAIL=$3
PASS=$4

/usr/lib/mailman/bin/newlist -l fr -q $LIST $MAIL $PASS
/usr/lib/mailman/bin/config_list -i $IN/$LIST.conf $LIST
/usr/lib/mailman/bin/add_members -r $IN/$LIST-regular.txt $LIST
/usr/lib/mailman/bin/add_members -d $IN/$LIST-digest.txt $LIST

#restore archive
cd /var/lib/mailman/archives/private
tar xzf $IN/$LIST-archive.tgz
tar xzf $IN/$LIST-mbox-archive.tgz
chown -R apache:mailman $LIST $LIST.mbox

}


OUT=/tmp/
savelist mylist  $OUT
/usr/lib/mailman/bin/rmlist mylist

PASS=xxx
MAIL=me@xxx.com
loadlist mylist  /tmp/ $MAIL $PASS
Comment 5 Jan Kaluža 2012-09-26 05:40:57 EDT
Thanks for letting me now.

Note You need to log in before you can comment on or make changes to this bug.