Bug 853883 - [ovirt-engine-backend] logging: vdsBroker logs shows only vds id in (request to add vds name)
[ovirt-engine-backend] logging: vdsBroker logs shows only vds id in (request ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Yaniv Bronhaim
Dafna Ron
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 04:49 EDT by Dafna Ron
Modified: 2016-02-10 14:32 EST (History)
10 users (show)

See Also:
Fixed In Version: si19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (87.89 KB, application/x-xz)
2012-09-03 04:49 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-03 04:49:30 EDT
Created attachment 609298 [details]
log

Description of problem:

the engine log is showing only vds id in the logs. since the users do not know what the vds id is without checking the db it makes it really hard to debug. 


Version-Release number of selected component (if applicable):

si16

How reproducible:

100%

Steps to Reproduce:
1. look at commands like GetDeviceList
2.
3.
  
Actual results:

we only see vds id

Expected results:

vds name should be added to all commands as well as the vds id - it will make it easier to debug when there is more than one host in the cluster. 

Additional info: backend log


example - GetDeviceList is sent to vds - how do we know which one it is? 

2012-09-03 11:15:56,731 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetDeviceListVDSCommand] (ajp-/127.0.0.1:8009-8) [4a7e0b1f] START, GetDeviceListVDSCommand(vdsId = 8c28
9d3a-f4d7-11e1-8cda-001a4a169741, storageType=ISCSI), log id: 3acd1676
Comment 6 Yaniv Bronhaim 2012-09-09 07:59:36 EDT
upstream patch: http://gerrit.ovirt.org/#/c/7861/
and additional fix: http://gerrit.ovirt.org/#/c/7865/
Comment 8 Dafna Ron 2012-09-27 09:02:36 EDT
verified on si19

Note You need to log in before you can comment on or make changes to this bug.