Bug 853939 - Error on click of "logs" button
Error on click of "logs" button
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 07:25 EDT by Rehana
Modified: 2012-12-04 10:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A new source_type variable for events caused Cloud Engine to display an error when viewing the Logs page. This fix filters events unrelated to applications and instance. Users now view the Logs page without error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_err (58.67 KB, image/png)
2012-09-03 07:25 EDT, Rehana
no flags Details
rails log (13.14 KB, text/x-log)
2012-09-03 07:25 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-09-03 07:25:01 EDT
Created attachment 609331 [details]
log_err

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Installed aeolus nightly from fedora repo
2.Started some instances
3.Go to monitor --> Logs
  
Actual results:
Obsereved that "Association named 'pool_family' was not found; perhaps you misspelled it? " error got displayed (PFA:log_err.png,rails.log

Expected results:
Should display all instance logs

Additional info:
rpm -qa | grep aeolus
aeolus-conductor-doc-0.13.0-0.20120903030010git55da509.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120902230031git902c81c.fc16.noarch
aeolus-conductor-0.13.0-0.20120903030010git55da509.fc16.noarch
aeolus-configure-2.8.0-0.20120902230026git7dfddaf.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120903030010git55da509.fc16.noarch
aeolus-all-0.13.0-0.20120903030010git55da509.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120902230028gitd64d64f.fc16.noarch
Comment 1 Rehana 2012-09-03 07:25:50 EDT
Created attachment 609332 [details]
rails log
Comment 3 Tzu-Mainn Chen 2012-09-06 00:27:34 EDT
Pushed to master/1.1:

commit 25db33f8dbc171c8a903f035005cb7b3cc109f9c
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Wed Sep 5 13:56:09 2012 -0400

    BZ853939 specify event source_type to prevent unwanted events from creeping into logs page
Comment 5 Steve Linabery 2012-09-07 18:02:21 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 7 Aziza Karol 2012-09-17 06:05:08 EDT
No error when clicked on logs button.

verified:
#rpm -qa | grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
Comment 9 errata-xmlrpc 2012-12-04 10:18:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.