Bug 853961 - power-off/reboot results in log out after a long timeout
power-off/reboot results in log out after a long timeout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-03 08:28 EDT by Kamil Páral
Modified: 2012-10-03 04:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 04:02:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages after attempt to power off (45.62 KB, text/plain)
2012-09-03 08:28 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-09-03 08:28:13 EDT
Description of problem:
If I try to restart/power-off computer using user menu, it waits a long time (I measured 50 seconds) and then user is brought back to gdm screen.

Version-Release number of selected component (if applicable):
gnome-session-3.5.5-1.fc18
gdm-3.5.90-1.fc18
systemd-188-3.fc18

How reproducible:
seems always

Steps to Reproduce:
1. log in
2. try to reboot/power off
3. wait and see gdm
Comment 1 Kamil Páral 2012-09-03 08:28:40 EDT
Created attachment 609368 [details]
messages after attempt to power off
Comment 2 Kamil Páral 2012-09-03 08:29:34 EDT
" All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work "
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 3 Matthias Clasen 2012-09-26 11:57:58 EDT
Just to be clear, this is a bug about the power menu on the login screen ?
Or about the power off menu item in the user menu in the session ?
Comment 4 Kamil Páral 2012-09-26 12:00:29 EDT
User menu in the session.

There was a similar bug caused by selinux, I should re-test this whether it is still broken or not.
Comment 5 Adam Williamson 2012-09-26 12:54:51 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . As reported it would be a blocker, but Kamil says he hasn't seen it lately, and other testers running F18 (myself and viking-ice) reported that we had not seen this issue, so it doesn't seem to be that straightforward. We agreed to delay the decision on this bug while Kamil re-tests it and others see if they can trigger it.
Comment 6 Kamil Páral 2012-10-03 04:02:30 EDT
This seems to work well now:

selinux-policy-3.11.1-25.fc18.noarch
systemd-188-3.fc18.x86_64
gdm-3.6.0-1.fc18.x86_64
gnome-session-3.6.0-1.fc18.x86_64

Note You need to log in before you can comment on or make changes to this bug.