Bug 853964 - gdm freezes after authentication failure
gdm freezes after authentication failure
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-03 08:37 EDT by Kamil Páral
Modified: 2012-10-03 03:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 14:45:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration video (166.83 KB, video/ogg)
2012-09-03 08:37 EDT, Kamil Páral
no flags Details
messages since the time I tried to log in (12.20 KB, text/plain)
2012-09-03 08:42 EDT, Kamil Páral
no flags Details
greeter.log (1.47 KB, text/plain)
2012-09-03 08:42 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-09-03 08:37:20 EDT
Created attachment 609371 [details]
bug demonstration video

Description of problem:
If you provide a wrong password and try to log in again, gdm freezes. See video.

Version-Release number of selected component (if applicable):
gdm-3.5.90-1.fc18

How reproducible:
always

Steps to Reproduce:
1. provide wrong password
2. click on your account name again
Comment 1 Kamil Páral 2012-09-03 08:42:31 EDT
Created attachment 609372 [details]
messages since the time I tried to log in
Comment 2 Kamil Páral 2012-09-03 08:42:46 EDT
Created attachment 609373 [details]
greeter.log
Comment 3 Kamil Páral 2012-09-03 08:44:19 EDT
Nominating for blocker:
" When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should provide a working login prompt without any unintended user intervention when boot is complete, and all virtual consoles intended to provide a working login prompt should do so "
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 4 Pratyush Sahay 2012-09-03 12:49:56 EDT
Reproducible here also. Steps same as Comment 1 above. Blank GDM (no text / icon / options) shows up.
Comment 5 Jens Petersen 2012-09-07 04:44:41 EDT
Or even just press Cancel for the same effect.


Actual result:
2. user icon appears but no password box not Cancel/Sign In buttons.

Expected result:
2. login to be possible second time.
Comment 6 Jens Petersen 2012-09-07 04:45:20 EDT
oh and yes this still happens with gdm-3.5.91-1.fc18.
Comment 7 Ray Strode [halfline] 2012-09-07 10:35:19 EDT
this should be fixed with gnome-shell-3.5.91-1.fc18
Comment 8 Pratyush Sahay 2012-09-11 10:28:34 EDT
This is still there in F18 Alpha RC2. Havent checked gnome-shell version in Alpha RC2. Two ways to reproduce:

FIRST:

Steps:
1) Click on user
2) Enter wrong password
3) In the menu that shows up, click "Not Listed"
4) GDM freeze

How reproducible:
always

SECOND:

Steps:
1) Click on user
2) Enter wrong password
3) In the menu that shows up, click on the same user as in 1)
4) GDM freeze

How reproducible:
mostly
Comment 9 Matthias Clasen 2012-09-26 12:00:19 EDT
Should be fixed in current packages.
Comment 10 Adam Williamson 2012-09-26 13:02:40 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Accepted as a blocker per criterion "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria must boot to a working graphical environment without unintended user intervention." , though we agreed this criterion isn't ideal and I will draft some better ones to enforce the https://fedoraproject.org/wiki/QA:Testcase_desktop_login test case.

Marking as ON_QA on the basis that it's expected to be fixed in I guess 3.5.92, please re-test with that GDM/GNOME.
Comment 11 Pratyush Sahay 2012-09-29 02:16:43 EDT
Just tested on fully updated F18. Issue seems to have been resolved.

$ rpm -qa | grep gdm
gdm-3.6.0-1.fc18.x86_64
Comment 12 Adam Williamson 2012-10-02 14:45:56 EDT
We're up to 3.6.0 in stable now, so let's close this.
Comment 13 Kamil Páral 2012-10-03 03:20:43 EDT
Confirmed fixed.

Note You need to log in before you can comment on or make changes to this bug.