Bug 853974 - [RFE] [LOG] "Domain is either partially accessible or entirely inaccessible" error in vdsm log is very general which makes debugging hard
[RFE] [LOG] "Domain is either partially accessible or entirely inaccessible" ...
Status: CLOSED WONTFIX
Product: vdsm
Classification: oVirt
Component: RFEs (Show other bugs)
---
x86_64 Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Allon Mureinik
Raz Tamir
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 09:08 EDT by Dafna Ron
Modified: 2017-11-26 07:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-26 07:58:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
logs (6.63 MB, application/x-gzip)
2012-09-03 09:08 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-03 09:08:05 EDT
Created attachment 609380 [details]
logs

Description of problem:

the following error in vdsm log is not very helpful for debugging an access list issue:

StorageDomainAccessError: Domain is either partially accessible or entirely inaccessible

this makes debug really hard.
I have seen the same error when blocking storage from hosts in a domain created from luns which are on several storage servers and this is the same error we are getting for access list issues (which are harder for admin to debug). 


Version-Release number of selected component (if applicable):

si16
vdsm-4.9.6-31.0.el6_3.x86_64

How reproducible:

100%

Steps to Reproduce:
1. create a setup with several domains complied out of luns from different servers
2. remove hosts from one of the storage's access list
3. 
  
Actual results:

Error in vdsm log only explains that the domain is inaccessible - this is the same error I would get for many storage issues. 

Expected results:

we should add some more error's for specific issues in vdsm to allow the administrator to debug the issue faster and fix it. 

Additional info: logs

i think that this issue is extremely important since in a large company guessing what the problem with the storage is can take several hours (depending on how complicated the network is and how experienced and creative the administrator is)
Comment 2 Ayal Baron 2012-09-06 08:42:47 EDT
I'm assuming you're referring to:

17:25:24,408::domainMonitor::191::Storage.DomainMonitor
...
StorageDomainAccessError: Domain is either partially accessible or entirely inaccessible: ('bc7fde7a-4d43-4dd4-874a-bff5ca517bae',)

This is in the domain monitor, so to pass this info up to engine we need to expose it in getVdsStats (getRepoStats to be exact).

Note You need to log in before you can comment on or make changes to this bug.