Bug 85398 - process that hangs and will not be killed
process that hangs and will not be killed
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-28 21:27 EST by Need Real Name
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 14:56:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This was the output of dmesg when I had an unkillable process (14.98 KB, text/plain)
2003-03-05 16:52 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-02-28 21:27:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I run a c program that hangs for some reason (I'm not talking about rpm. I
noticed there were bug reports about rpm hanging but this is
just  simple c program). I run the program, it starts running and printing
verbose messages to the screen, then it hangs and the screen
freezes,  I try to control-c
out of it but it doesn't work. I then try to kill it using
kill pid then kill -9 pid.  It doesn't work. I have had this problem on
two machines that I have upgraded to 8.0. I also look at top and do not see the
process running. If I keep trying to run the program it will hang again and make
another unkillable process. If I reboot the machine and then try to run the
program it runs fine. It happens occasionally and the machine must be rebooted
or the process must be left to hang until a conveniant time to reboot the
machine is found. 
So far this has always happened with programs that were reading files 
on a nfs mounted partition. 
I put this under sh-utils because I thought maybe it's a problem with the kill
command but maybe it belongs elsewhere.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.I run c programs. eventually one hangs
2. If I am not running the program in the background I try to control-c to interrupt
3.I use ps-ax to find the pid number and try to kill the program  kill <PID>
then kill -9 <PID>
    

Actual Results:  The program persists. It shows up on ps -ax although not on top.

Expected Results:  kill -9 pid should have killed the program

Additional info:

I did not have this problem with redhat7.2.
Comment 1 Tim Waugh 2003-03-01 07:43:31 EST
When this happens, does 'dmesg' show any alarming messages?  This sounds like it
might be a kernel problem.
Comment 2 Need Real Name 2003-03-05 16:52:57 EST
Created attachment 90483 [details]
This was the output of dmesg when I had an unkillable process

The process is in uninterruptable sleep.
Comment 3 Tim Waugh 2003-03-05 17:09:35 EST
Certainly not a sh-utils problem anyway.  Changing component.
Comment 4 Arjan van de Ven 2003-03-05 17:15:14 EST
could you enable magic-sysreq (see the /etc/sysctl.config file) and then press
sysreq-t ? that will spew a lot of stuff but that will usually be the right info
for chasing such uninterruptible hangs.

Note You need to log in before you can comment on or make changes to this bug.