Bug 853982 - Network info is not sent to OCS server
Network info is not sent to OCS server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ocsinventory-agent (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 09:37 EDT by John Kissane
Modified: 2012-12-13 02:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 02:30:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Kissane 2012-09-03 09:37:53 EDT
Description of problem:
ocsinventory-agent does not send the network information to the server in Fedora 17

Version-Release number of selected component (if applicable):
2.0.5-1.fc17

How reproducible:
100%

Steps to Reproduce:
1. Setup an F17 client & install the OCS agent
2. Check on the server if the IP address of the client is available
3.
  
Actual results:
Client info on OCS server lacks the network inforlation

Expected results:
Network info such as MAC address & IP address available

Additional info:
Probably due to the different layout of the 'ifconfig' out in F17:

Eg: F16 host


lnxd4bed999c3ce (42) ifconfig em1
em1       Link encap:Ethernet  HWaddr D4:BE:D9:99:C3:CE  
          inet addr:10.1.65.175  Bcast:10.1.255.255  Mask:255.255.0.0
          inet6 addr: fe80::d6be:d9ff:fe99:c3ce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4345512 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1681257 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4767580243 (4.4 GiB)  TX bytes:564583884 (538.4 MiB)
          Interrupt:20 Memory:e1a00000-e1a20000 

F17 host:

lnx0023ae8c33b6 (42) ifconfig em1
em1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.1.65.145  netmask 255.255.0.0  broadcast 10.1.255.255
        inet6 fe80::223:aeff:fe8c:33b6  prefixlen 64  scopeid 0x20<link>
        ether 00:23:ae:8c:33:b6  txqueuelen 1000  (Ethernet)
        RX packets 4634814  bytes 4923336168 (4.5 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1736369  bytes 1125167322 (1.0 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 21  memory 0xf7ae0000-f7b00000
Comment 1 Remi Collet 2012-09-03 10:26:29 EDT
Verified.

Reported upstream with patch.
https://bugs.launchpad.net/ocsinventory-unix-agent/+bug/1045356
Comment 2 Fedora Update System 2012-09-23 13:42:57 EDT
ocsinventory-agent-2.0.5-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ocsinventory-agent-2.0.5-4.fc18
Comment 3 Fedora Update System 2012-09-23 13:43:22 EDT
ocsinventory-agent-2.0.5-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ocsinventory-agent-2.0.5-4.fc17
Comment 4 Fedora Update System 2012-09-23 19:50:12 EDT
Package ocsinventory-agent-2.0.5-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ocsinventory-agent-2.0.5-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14648/ocsinventory-agent-2.0.5-4.fc17
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.