Bug 853985 - KDM autologin does not work on Live
KDM autologin does not work on Live
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-03 09:44 EDT by Jaroslav Reznik
Modified: 2013-06-08 17:17 EDT (History)
14 users (show)

See Also:
Fixed In Version: 4.9-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 19:19:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch (305 bytes, patch)
2012-09-03 13:52 EDT, Daniel Vrátil
no flags Details | Diff

  None (edit)
Description Jaroslav Reznik 2012-09-03 09:44:11 EDT
Description of problem: KDM autologin does not work on Live, user has to manually insert liveuser user to log into the Live system. fedora-live-kde-base.ks contains the required bits, it's correctly set on the system. After killing kdm and restarting - autologin works. So probably kdm.service starts too early and is missing something (pam related etc?).

Steps to Reproduce:
1. boot Fedora 18 Alpha TC5
2. KDM should autolog liveuser user
  
Actual results:
No autologin, user has to manually insert liveuser user

Expected results:
KDM logs liveuser automatically (or for Alpha - liveuser is preselected)
Comment 1 Jaroslav Reznik 2012-09-03 09:47:25 EDT
Proposing as Alpha blocker: "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied"

User has to know about liveuser user and put it into KDM login form.
Comment 2 Jaroslav Reznik 2012-09-03 09:54:13 EDT
One guess - kdm services starts before livesys? So After=livesys-late.service (or just livesys.service) should help?
Comment 3 Kevin Kofler 2012-09-03 13:04:16 EDT
This has been reported by nucleo and caravel on IRC already, but AFAICT they didn't file a bug yet, so it was good to file this one.

According to nucleo, the issue appears to be that the X server in the autologin session is crashing, which logs you out and drops you back to KDM, where you can then login manually.

This might be related to firstboot: The SoaS people have reported that firstboot is starting on their live image, which it shouldn't do. (It's only supposed to run on installed systems, not live images.) But it might also be completely unrelated to firstboot.
Comment 4 Daniel Vrátil 2012-09-03 13:52:26 EDT
Created attachment 609451 [details]
Patch

I tried adding livesys-late.service to After field in kdm.service as Jaroslav suggested and it fixes the issue for me. 

I've made two live images using livecd-creator and the fedora-livecd-kde.ks script from /usr/share/spin-kickstarts. Without the attached patch the autologin does not work, with patched kickstart script KDM autologin works perfectly. I tried rebooting both VMs a few times to make sure it's not a random issue and the behavior was consistent.
Comment 5 Fedora Update System 2012-09-04 07:40:10 EDT
kde-settings-4.9-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kde-settings-4.9-9.fc18
Comment 6 Fedora Update System 2012-09-04 12:54:52 EDT
Package kde-settings-4.9-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-settings-4.9-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13304/kde-settings-4.9-9.fc18
then log in and leave karma (feedback).
Comment 7 Adam Williamson 2012-09-05 12:22:44 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion cited in original report for the sake of time, though we note that the criterion does not cover live images as written. We consider this an oversight, however, that will be rectified in the criteria. There is a workaround - type 'liveuser' in the username box - but we considered this not a good enough workaround as you have to know the name of the user, which isn't something we can expect everyone to know. KDM does not present a user list as GDM does.
Comment 8 Petr Schindler 2012-09-06 09:13:31 EDT
This bug is fixed in 64bit TC6 live-kde.
Comment 9 Fedora Update System 2012-09-07 19:19:47 EDT
kde-settings-4.9-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Massimiliano 2013-06-08 17:17:00 EDT
This bug still (or again) affects recent builds (see http://alt.fedoraproject.org/pub/alt/live-respins/) of F18 and also my remix:

# rpm -qa kde-set\*
kde-settings-ksplash-4.9-21.fc18.noarch
kde-settings-pulseaudio-4.9-21.fc18.noarch
kde-settings-4.9-21.fc18.noarch
kde-settings-kdm-4.9-21.fc18.noarch
kde-settings-plasma-4.9-21.fc18.noarch

Note You need to log in before you can comment on or make changes to this bug.