Bug 853988 - liveinstall: kernel panic - unable to mount root fs on unknown-block(0,0)
liveinstall: kernel panic - unable to mount root fs on unknown-block(0,0)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-03 09:47 EDT by Kamil Páral
Modified: 2012-09-17 19:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.6.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:53:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic during boot (9.60 KB, image/png)
2012-09-03 09:47 EDT, Kamil Páral
no flags Details
grub (274.53 KB, image/png)
2012-09-03 09:47 EDT, Kamil Páral
no flags Details
anaconda.log (4.58 KB, text/plain)
2012-09-05 04:50 EDT, Kamil Páral
no flags Details
storage.log (183.14 KB, text/plain)
2012-09-05 04:50 EDT, Kamil Páral
no flags Details
program.log (594.38 KB, application/x-xz)
2012-09-05 04:52 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-09-03 09:47:14 EDT
Created attachment 609392 [details]
kernel panic during boot

Description of problem:
I did an install of F18 Alpha TC5 i686 Live, all defaults. After reboot, I see:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

If I see grub menu, it has root=/dev/vda3 (is that correct for default anaconda install?), but it seems to lack any initrd item.

Version-Release number of selected component (if applicable):
F18 Alpha TC5 i686 Live

How reproducible:
always

Steps to Reproduce:
1. install live using defaults
2. reboot
Comment 1 Kamil Páral 2012-09-03 09:47:46 EDT
Created attachment 609393 [details]
grub
Comment 2 Kamil Páral 2012-09-03 09:48:21 EDT
Proposing as a blocker:
" In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account "
https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria
Comment 3 Adam Williamson 2012-09-04 00:51:43 EDT
+1 blocker per criterion cited.
Comment 4 Jaroslav Reznik 2012-09-04 09:56:43 EDT
+1 blocker.
Comment 5 Chris Lumens 2012-09-04 11:13:17 EDT
We need log files in order to debug installation problems.
Comment 6 Kamil Páral 2012-09-05 04:50:09 EDT
Created attachment 609905 [details]
anaconda.log
Comment 7 Kamil Páral 2012-09-05 04:50:26 EDT
Created attachment 609906 [details]
storage.log
Comment 8 Kamil Páral 2012-09-05 04:52:07 EDT
Created attachment 609908 [details]
program.log

program.log has 10MB, so I had to compress it. It is really intended to list every file on the filesystem in that log?
Comment 9 Vratislav Podzimek 2012-09-05 08:44:30 EDT
Anaconda calls grub2-mkconfig. But since there is only initrd-plymouth.img, which is ignored by grub2-mkconfig. Maybe anaconda should call 'dracut -f' in chroot before running grub2-mkconfig?
Comment 10 Adam Williamson 2012-09-05 13:21:41 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion "In most cases, a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. The firstboot utility must be able to create a working user account".
Comment 11 Fedora Update System 2012-09-07 16:17:04 EDT
anaconda-18.6.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.6-1.fc18
Comment 12 Fedora Update System 2012-09-08 15:25:35 EDT
Package anaconda-18.6.6-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.6-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13611/anaconda-18.6.6-1.fc18
then log in and leave karma (feedback).
Comment 13 Kamil Páral 2012-09-11 07:48:52 EDT
This is fixed with F18 Alpha RC2. System boots, initrd is not missing.
Comment 14 Adam Williamson 2012-09-17 18:53:56 EDT
18.6.7 went stable, so closing this.
Comment 15 Fedora Update System 2012-09-17 19:57:32 EDT
anaconda-18.6.6-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.