Bug 8540 - some words about packaging
some words about packaging
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 7479 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-17 12:15 EST by pavel.janik
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-16 18:21:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pavel.janik 2000-01-17 12:15:35 EST
Hello,

just got to check Rawhide's emacs package, so:

1. - Prereq: /sbin/install-info is needed to have info pages correctly
installed

2. PUREDEF and XPUREDEF are empty so I propose to remove them

3. Why si libtoolize called?

4. shouldn't be optimalization left out for -nox too?

5. there is something like this in spec:-)

#Build binary with X support
[ -d build-withx ] && rm -rf build-withx
mkdir build-withx && cd build-withx
CFLAGS="$RPM_OPT_FLAGS $XPUREDEF" LDFLAGS=-s \
CFLAGS="$XPUREDEF" LDFLAGS=-s \
  ../configure ${CONFOPTS} --with-x-toolkit ${RPM_ARCH}-redhat-linux-gnu
make
cd ..

I do not think that both CFLAGS and LDFLAGS should be used :-))

6. /usr/lib/emacs/site-lisp should be removed - we have
/usr/share/emacs/site-lisp

7. LDFLAGS=-s is used so any strip does not have reason...

8. recompilation of patched mh-utils.el should be added

9. I propose also updating gnus to newer version because it is terrible to
distribute (in Emacs, not in RH) old version of main news and mail client.

10. site-lisp directories do not contain subdirs.el files

I think this is everything. Plese keep me informed about changes you agree
with. Thank you.
Comment 1 pavel.janik 2000-01-17 12:52:59 EST
I'm just uploading emacs-20.5a-3.src.rpm to incoming.redhat.com with all of
these things fixed.
Comment 2 Cristian Gafton 2000-02-16 13:00:59 EST
1. you're right, fixed.

2. they're not empty anymore

3. because we need to pull in the latest config.guess for weird architectures.

4. optimization is on for everybody now

5. doh. that was dumb, fixed.

6. not really - emacs still likes toi check every once in a while. dunno why.

7. you're right

8. done (I think)

9. I'd rather not go there and start updating random packages within emacs

10. done again (I think)
Comment 3 Cristian Gafton 2000-02-16 13:02:59 EST
Can you mail me a diff for your spec file? incoming.redhat.com is a mess now and
your package update was messed up.
Comment 4 Cristian Gafton 2000-02-16 13:04:59 EST
*** Bug 7479 has been marked as a duplicate of this bug. ***
Comment 5 pavel.janik 2000-02-16 13:14:59 EST
Where is it fixed? In emacs-20.5-5 in Rawhide? I will send you the diff tomorrow
because I do not have it here.
Comment 6 Cristian Gafton 2000-02-16 18:21:59 EST
rawhide will be updated at the end of the week.
Comment 7 pavel.janik 2000-02-21 09:22:59 EST
it is not :-( Can you send me the package via mail? Thank you.

Note You need to log in before you can comment on or make changes to this bug.