Bug 85400 - Sound Blaster Live! Card is detected, but no sound
Sound Blaster Live! Card is detected, but no sound
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-soundcard (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-28 21:38 EST by Mike Chambers
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-20 15:53:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2003-02-28 21:38:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
The card is detected fine, but there is no sound.  I believe this has to do with
Digital Output.  I have to enable this in Windows 2000/XP to hear it there too.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-soundcard
2.After install/configuration, try to play a sound
3.
    

Actual Results:  Card is detected, but no sound.

Expected Results:  Should be able to hear sounds

Additional info:

As mentioned above, maybe digital output needs to be included or as an option to
allow it to be enabled?
Comment 1 Brent Fox 2003-03-03 16:09:40 EST
Does the analog output work ok?
Comment 2 Mike Chambers 2003-03-03 17:10:55 EST
Not sure what you want here.  Analog output? (give me a command to do or what to
check if need be, sort of lost on this one)
Comment 3 Brent Fox 2003-03-04 12:35:35 EST
Well, as I understand it, the digital out on the SB Live is the S-PDIF
connector.  This is the big yellow multi-pin connector on the back of the card.

The analog output is the green 1/8" connector in the back.  Are your speakers
plugged into this port or are they plugged into the S-PDIF connector?

I think that the surround sound speaker systems use the S-PDIF connector while
regular speakers (the smaller left/right computer speakers) use the analog
connector.  I have never tested the S-PDIF connector since I don't have a fancy
speaker system.  It's possible that the S-PDIF connector doesn't work with the
SB Live drivers in Linux.
Comment 4 Mike Chambers 2003-03-04 12:52:54 EST
First off, my card has 4 little different colored ports (speaker out, aux in,
mic, and I think another for speaker out), all I guess 1/8" connectors.  Then it
has a big one, which is for a joystick I am assuming.

My system is connected this way..

1 - Woofer plugged into 2nd port (green)
2 - One desktop speaker plugged into the woofer
3 - One desktop speaker plugged into the other desktop speaker

I will add, that I did get ALSA installed and ran alsamixer and when I got to
the analog/digital output part, when I hit M or < > I did hear a pop or whatever
out of the speaker, like it was just turned on.  So I believe digital output
(like in XP and 2000) is needed to get it working.  I just haven't had a way to
test it yet (need to get some mp3's or ogg files or something)
Comment 5 Brent Fox 2003-03-20 15:53:58 EST
Your setup sound identical to mine, but mine works fine without having to
install ALSA.  I have my subwoofer plugged into the green port, with one desktop
speaker plugged into the sub and the other desktop speaker plugged into the
first desktop speaker.  

I'm not sure why this wouldn't work for you and I'm not having any luck
reproducing your situtaion.  I don't know what else to do except close as
'worksforme.'
Comment 6 Mike Chambers 2003-03-20 20:28:22 EST
I checked the back of the card and the woofer to make sure I wasn't missing
something.  I found out that the output connection on the back of the woofer is
"digital output" (it's written right on the back of the woofer) which then goes
out to the desktop speakers.  Digital output is needed on XP, and I downloaded
emu-tools to see if I can enable it there too but nto sure I am doing it right.
 If I get it working I will let you know what I did, and find out if still a bug
or not.  Will leave as closed until I can troubleshoot more.
Comment 7 Ray Finley 2005-03-16 12:08:03 EST
Same issue here.  SB Live found find, test 'sound' plays, however NO CD or other
audio works.
Comment 8 Ray Finley 2005-03-16 12:11:29 EST
I realize this is an old thread, if there has been a solution please point me to
it.  I have the following

Fedora Core 3, ALL UPDATES
SB LIVE 

Simple set of speakers connected to GREEN OUT audio out


Comment 9 Brent Fox 2005-03-16 12:26:18 EST
If you are seeing this with FC3, please open a new bug report.  Many things have
changed since the Phoebe beta release 2 years ago.

Note You need to log in before you can comment on or make changes to this bug.