Bug 854041 - apiviz: Missing graphviz requires
Summary: apiviz: Missing graphviz requires
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apiviz
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Goldmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-03 16:58 UTC by Mikolaj Izdebski
Modified: 2012-09-27 05:02 UTC (History)
1 user (show)

Fixed In Version: 1.3.1-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-18 10:29:05 UTC
Type: Bug


Attachments (Terms of Use)
Patch fixing the problem (1.26 KB, patch)
2012-09-03 16:58 UTC, Mikolaj Izdebski
no flags Details | Diff

Description Mikolaj Izdebski 2012-09-03 16:58:04 UTC
Created attachment 609445 [details]
Patch fixing the problem

Description of problem:
apiviz is executing /usr/bin/dot from graphviz package, so it should have dependency on graphviz.
See: ./apiviz-1.3.1.GA/src/main/java/org/jboss/apiviz/Graphviz.java

Comment 1 Marek Goldmann 2012-09-18 10:29:05 UTC
Thanks, pushed, fixed in 1.3.1-8.

Comment 2 Fedora Update System 2012-09-18 10:57:15 UTC
apiviz-1.3.1-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/apiviz-1.3.1-8.fc17

Comment 3 Fedora Update System 2012-09-18 10:57:25 UTC
apiviz-1.3.1-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/apiviz-1.3.1-8.fc18

Comment 4 Fedora Update System 2012-09-27 04:19:05 UTC
apiviz-1.3.1-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2012-09-27 05:02:53 UTC
apiviz-1.3.1-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.