Bug 854051 - Encoded filenames when saving attachments
Encoded filenames when saving attachments
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 15:13 EDT by Mikhail
Modified: 2013-02-20 06:03 EST (History)
4 users (show)

See Also:
Fixed In Version: evolution-3.6.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 06:03:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Evolution screenshot (250.30 KB, image/png)
2012-09-03 15:13 EDT, Mikhail
no flags Details
message which demonstrate it (125.55 KB, application/mbox)
2012-09-03 15:13 EDT, Mikhail
no flags Details
Not fixed (100.28 KB, image/png)
2013-02-19 09:19 EST, Mikhail
no flags Details
mbox (125.56 KB, application/mbox)
2013-02-19 09:29 EST, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-09-03 15:13:07 EDT
Created attachment 609464 [details]
Evolution screenshot

Description of problem:
File names contain artefacts (evlolution-ews)
Comment 1 Mikhail 2012-09-03 15:13:58 EDT
Created attachment 609465 [details]
message which demonstrate it
Comment 2 Milan Crha 2012-09-04 07:44:57 EDT
Thanks for a bug report. I've a feeling we did try to fix this already, or at least something close to it. Maybe, it was about file names, not message subjects. Nonetheless, the 3.5.91 shows attachments quite differently from 3.4.4, after I imported your message to my local folder, thus I'm CC'ing Dan, whom knows the internals the best these days.
Comment 3 Mikhail 2013-02-19 09:19:35 EST
Created attachment 699468 [details]
Not fixed
Comment 4 Mikhail 2013-02-19 09:27:30 EST
1) I see included email's as attachment.dat file and can't open separately.
2) Encoding into included messages are bad
Comment 5 Mikhail 2013-02-19 09:29:38 EST
Created attachment 699469 [details]
mbox
Comment 6 Mikhail 2013-02-19 09:30:07 EST
Evolution version 3.6.3
Comment 7 Milan Crha 2013-02-20 02:54:03 EST
Thanks for the update. There were done a fix in evolution to have the View->Character Encoding working, thus, as a workaround, you can pick one of the Cyrillic or other character sets to show the letters and then it may provide you with a correct view.

I see from the first internal message that the text/plain part has set no charset, while the text/html part has set charset="CP20866", while the html part itself claims to be content="text/html; charset=koi8-r".

It would be interesting to get a raw message as is stored on your exchange server, to try to reproduce it here. Maybe if your server allows IMAP access, then download the message through it, rather than let parsing all the things evolution-ews. It would be also interesting to know how the message attachment was created, and in which client, as the issue can be also during the time of message attachment creation, not storing character set properly. You might be able to check how OWA behaves on the message too.
Comment 8 Mikhail 2013-02-20 03:15:23 EST
https://docs.google.com/file/d/0B0nwzlfiB4aQYWRRTmFocnZXYnM/edit?usp=sharing

Thanks, manually setted encoding KOI8-R helps to read attached messages.

How open each attached messages separately?

Seems this glitch message I was created with old Evolution version which not correctly work with CP20866 encoding.
Comment 9 Milan Crha 2013-02-20 04:10:51 EST
From the MAPI code, CP20866 is used for koir-8 charset:
http://git.gnome.org/browse/evolution-mapi/tree/src/libexchangemapi/e-mapi-mail-utils.c#n200
Comment 10 Milan Crha 2013-02-20 04:17:50 EST
(In reply to comment #8)
> How open each attached messages separately?

The attached messages cannot be opened separately in evolution itself, if I recall correctly, you can open them in an editor, as one of the options worked in your video. I do not know why the other did not, though.

> Seems this glitch message I was created with old Evolution version which not
> correctly work with CP20866 encoding.

Aha, I see, it makes sense. I guess the message was created by evolution-mapi, in times when it didn't know about koir-8, and attaching it used it as is, which means broken. I believe this bug is obsolete in 3.6.x, and newly created and/or received messages will not suffer of this issue.
Comment 11 Mikhail 2013-02-20 04:33:51 EST
https://docs.google.com/file/d/0B0nwzlfiB4aQaVlYdkR4cmZ4ODg/edit?usp=sharing

1. Why Evolution offers base64 encoded filename?

2. Why I can't show mbox file without import???
Comment 12 Milan Crha 2013-02-20 04:56:56 EST
(In reply to comment #11)
> 1. Why Evolution offers base64 encoded filename?

Aah, you mean when saving attachments. I though it was in a view, where I saw all the message names decoded properly with your message. I'm sorry for a misunderstanding.

> 2. Why I can't show mbox file without import???

Because it's not implemented (yet). There might be filled a bug report upstream about the same for evolution, but if it's not, then feel free to create it there.
Comment 13 Milan Crha 2013-02-20 05:38:25 EST
With respect of Edit as New->Attachment->Save as, I committed a change for 3.7.91+ and 3.6.4+ in evolution to decode the filename first, thus it's better now.

I didn't figure out why the offered filename is "attachment.dat", instead of the $Subject.mbox variant when viewing the message in a preview panel and trying to save it, yet.
Comment 14 Milan Crha 2013-02-20 06:03:36 EST
OK, and for the same versions also a Subject is used as a filename when saving from preview. note the resulting file is not an mbox, thus I didn't add the file extension to the name. The attachment is saved exactly the same as it is in the original message itself.

Note You need to log in before you can comment on or make changes to this bug.