Bug 854087 - [RFE] report which locales have recent changes
Summary: [RFE] report which locales have recent changes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI   
(Show other bugs)
Version: 1.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Alex Eng
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-04 01:59 UTC by Ruediger Landmann
Modified: 2013-11-27 03:22 UTC (History)
3 users (show)

Fixed In Version: 2.3-SNAPSHOT (20130306-1233)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 03:22:13 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ruediger Landmann 2012-09-04 01:59:38 UTC
Description of problem:
There is presently no way to tell which languages (if any) have been recently updated in a project. If project maintainers had a way of knowing this, it would save time pushing and pulling translations, reduce server load, and reduce the chances of accidentally clobbering translations that have come into a project through other channels.

Ideally, this information would be available both on the web UI (like Transifex does) and via the command-line client. The command-line client would ideally report both files that had changed on the server since the last push and files that had changed locally since the last push (due to a translator committing directly to the repo, for example).

Comment 1 Runa Bhattacharjee 2012-11-26 18:27:25 UTC
Technical evaluation requested. Thanks

Comment 2 Alex Eng 2013-02-19 01:46:49 UTC
For UI changes, perhaps having a "last modified" column in the locale page with sorting capability would help with the navigation.

Comment 5 Ding-Yi Chen 2013-03-06 05:01:11 UTC
VERIFIED with Zanata version 2.3-SNAPSHOT (20130306-1233)
zanata-maven-plugin:2.2.1-SNAPSHOT
[INFO] client API version: 2.2.1-SNAPSHOT, server API version: 2.2.1-SNAPSHOT

Comment 6 Alex Eng 2013-03-11 00:32:44 UTC
Implemented cache for last modified information in document list view in both workspace and server side.

See
https://github.com/zanata/zanata/commit/bc9a29b12cbc2383a226b86c7a2e8a961cd6040c

Comment 7 Sean Flanigan 2013-11-27 03:22:13 UTC
Closing bugs which were VERIFIED with snapshots <= 3.1.


Note You need to log in before you can comment on or make changes to this bug.