Bug 8541 - Xconfigurator won't setup startx
Xconfigurator won't setup startx
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-17 12:46 EST by lare
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-18 18:01:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lare 2000-01-17 12:46:56 EST
While installing 6.1, the X configuration only offered me 640x480, not the
1600x1280 my system supports. My system uses a Matrox Millenium II with 8M
memory, and a Hitachi CM751 screen, both of which are supported. I ran
Xconfigurator, checked off 1600x1280, and it said that it couldn't
configure startx. This is strange because 6.0 was finally configured to
work correctly. Now, 6.1 won't run startx at all.

Also, while you're at it, will you free up my previous 6.0 account,
lreznick, because I haven't been able to use it since you changed your
software. I still had some questions on that while I still had support --
probably expired by now -- but couldn't get through at all because of your
software changes. Your software still says my lreznick account is present &
wouldn't let me register 6.1 using that name. I bought 6.1 because of all
the trouble I had getting support for 6.0 due to your software changes.
Comment 1 Trond Eivind Glomsrxd 2000-07-11 17:52:03 EDT
Uh.... startx doesn't need to be setup. Can you test this with 6.2, and in any
case give me the exact error messages?
Comment 2 lare 2000-07-12 12:00:55 EDT
Ah! Six months later, eh? I don't have the exact error message. It said that it couldn't configure startx. I don't have 6.2. I put this call in prior to the release 
of 6.2, so naturally, I expected support of 6.1. I have since worked around the problem. I presume that if I rerun Xconfigurator it would reproduce the 
problem, but I'm disinclined to take the chance of fouling my working system configuration.

So, tell me: if I upgrade to 6.2 and discover problems, will I have to wait six months for assistance? I have not had meaningful support from you through 
versions 6.0 & 6.1. Considering that I do UNIX network support for HP-UX, I do know something about support. What kind of support is it to put a 
problem on hold for six months, then to doubt that I even have the problem?
Comment 3 Trond Eivind Glomsrxd 2000-07-18 17:28:15 EDT
Sorry for the late reply - my guess is that the reason for the initial delay was
a sense of "this does not make sense" for the report itself. Shouldn't have
happened of course (I've just taken over development of the component, so I can
assure you no 6 months delay)
Comment 4 lare 2000-07-18 18:01:15 EDT
Thanks for your quicker reply. I've had so many problems with Red Hat 6.0 & 6.1 yet no consequential support that I have serious doubts about anyone 
without my kind of UNIX experience having lots of success using it. Every time I had to reinstall in the beginning I'd get different behavior & different 
installed software. Later this year, I'm inclined to bring it up to 6.2 unless you're going to a later version, but I cringe in anticipation of the new problems I'll 
get to play with.

Screen configuration has been the biggest beast because no two installations configured the same way, and the configuration that finally worked on 6.0 
didn't work on 6.1. Furthermore, 6.1's installation wouldn't start X once I got the screen configuration worked out. I had to manually set the inittab to start 
the right run level. Although Red Hat 6.x is better than what I've seen of earlier versions, it still seems not-ready-for-prime-time.
Comment 5 Trond Eivind Glomsrxd 2000-07-25 10:29:10 EDT
Xconfigurator in 6.2 will ask you if you want to boot into runlevel 5. When it
comes to hardware support, most supported hardware should work well but you will
have some cases where you will have problems. E.g., on my computers the last
couple of years I've just had to put in the CD or the bootfloppy (if somewhere
with a good Internet connection) and everything worked out of the box (with the
exception of newer HP Deskjets). BTW: the next release adds DDC probing to
Xconfigurator.
Comment 6 lare 2000-07-25 11:36:26 EDT
Xconfigurator typically set up booting into X, but not this time. Once I figured out what I had to do to get my resolution configured, the run level didn't start 
X. It took me a moment to determine that inittab had lost the initdefault setting.

As for hardware support, the only problems I had were 1) of my own mistake by not looking up support for the sound card, which has since been solved, 
and 2) discovering that there was no printer driver for the HP Officejet 350, but I've worked around that by using the Deskjet 500 settings -- not full 
capability, but it works.

On getting the new release, what would you propose? When 6.1 came out, I had had so much trouble getting support that I bought a new 6.1 package 
from the store to start support over again. During my 6.0 coverage, you guys changed your online support software and I couldn't get to my old account to 
start new calls or continue with my existing calls. While waiting for replies to this 6.1 call (you've been very helpful, thank you, so don't get the wrong idea), 
you guys moved to version 6.2. Now, I presume, you're going to 6.3. I'm not averse to paying a small fee to upgrade and get support, but the support 
needs to be more timely. What upgrade path or method would you suggest?
Comment 7 Trond Eivind Glomsrxd 2000-07-25 12:09:01 EDT
We're always working on improving support, and they are constantly getting
better. Happily, I don't do support (I'm a developer) but the people in support
I know are very good at what they do. If you want some support and the new 6.2
release, but are not sure how they are handling it right now, try the standard
edition - the support period isn't too long, but should be sufficient. It
doesn't have all the software in the DeLuxe edition, but it's much cheaper.
Comment 8 lare 2000-07-25 13:08:57 EDT
That's how I upgraded to 6.1. Based on that, I entered this call. You'll notice that the first entry in this call indicates a request about the previous support 
problem. That and my other calls have been ignored. I haven't seen any improvement in support and you're the first person who has been helpful. Well, 
this isn't your problem. So, is the next release coming soon enough that I needn't bother with 6.2?
Comment 9 Trond Eivind Glomsrxd 2000-07-25 13:19:24 EDT
This is not support, this is not a support call. This is a bug report facility
directly to us who develops the distribution. I've no knowledge whatsoever on
your support status, support calls etc - I just happen to be the person
developing Xconfigurator right now. 

As such, if the bug report doesn't look much like a bug or more of a support
question, you may not have a quick answer (or even an answer at all in some
cases, though I try do that)
Comment 10 lare 2000-07-25 14:21:36 EDT
I consider any problem report to be some kind of support call because a problem reported requests support. That the report might reveal a bug is a 
side-effect and should be handled, bringing in other people or another group as needed according to your categorizing of calls. When I logged this call, I 
explained what happened. The only place I could find at the time, January, to log this was in this location. I don't think it's appropriate for someone to look 
at a call, decide it's in the wrong place, and then ignore it. If there's a different group that handles the problem and due to customer error the call is in the 
wrong place, transfer it. Notify the customer that it got to the wrong place. Get someone more appropriate on the call.

I managed to work around the problem. I assume that the problem still exists and would be reproduceable. Now that I have the system working with 
respect to this call, I'm not inclined to bring it to its knees to reproduce the problem for you. Back in January or even February was the time to do that. 
Thank you very much for your advice, time, and interest in this. I do appreciate your effort. You can close this. When I upgrade, I will make a point of 
reporting everything that goes wrong and we'll see how the support has improved.
Comment 11 Trond Eivind Glomsrxd 2000-07-25 14:27:51 EDT
Sorry, but we have separate people, resources, tasks - they ask us if they need
to (hard issues), add bugs if needed etc. This is our public bug database, where
anyone can search for bugs (and solutions to these), add new bugs if these are
not found etc. If you mistook this for support, I'm sorry - it would indicate a
clearer labeling of the sites. Anyway - thanks for your input.
Comment 12 lare 2000-07-25 15:00:32 EDT
I didn't mistake it for support. I reported a bug in Xconfigurator on 6.1. Thanks.

Note You need to log in before you can comment on or make changes to this bug.