Bug 854107 - imount.c: In function 'mountCommandWrapper': error: format not a string literal and no format arguments
imount.c: In function 'mountCommandWrapper': error: format not a string liter...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 23:34 EDT by Leslie Zhai
Modified: 2013-04-12 07:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-12 07:43:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pyanaconda-isys-imount.patch (214 bytes, patch)
2012-09-03 23:34 EDT, Leslie Zhai
no flags Details | Diff

  None (edit)
Description Leslie Zhai 2012-09-03 23:34:40 EDT
Created attachment 609532 [details]
pyanaconda-isys-imount.patch

Description of problem:
make

imount.c: In function 'mountCommandWrapper':
imount.c:198:9: error: format not a string literal and no format arguments

Version-Release number of selected component (if applicable):
anaconda-18.6.5-1

How reproducible:
vi configure.ac comment iscsi
sh autogen.sh
./configure --disable-selinux

Steps to Reproduce:
1. make
2. make: *** [all] Error 2

Actual results:
./anaconda

Expected results:
imount.c error

Additional info:
Comment 1 Chris Lumens 2012-09-11 14:59:44 EDT
I am unable to reproduce this.  anaconda builds fine in our build system.
Comment 2 Florian Weimer 2013-04-12 07:42:21 EDT
The patch is correct and avoids crashes (or worse) when logging data which happens to contain '%' characters.
Comment 3 Florian Weimer 2013-04-12 07:43:46 EDT
But this appears to have been fixed with the rewrite.

Note You need to log in before you can comment on or make changes to this bug.