Bug 854168 - parted crashes when examining dd'd live iso.
parted crashes when examining dd'd live iso.
Status: CLOSED DUPLICATE of bug 835601
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-04 04:58 EDT by Petr Schindler
Modified: 2012-09-04 19:43 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 19:43:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
liveinst.log (84.27 KB, text/plain)
2012-09-04 05:33 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2012-09-04 04:58:03 EDT
Description of problem:
Liveinst is segfaulted when I run it from Live-KDE. In attachment 'liveinst.log' you can find what I get in terminal. This happens only on bare metal.

Sometimes it starts anaconda which takes 100% of cpu and nothing more happens.

Version-Release number of selected component (if applicable):
anaconda-18.6.4
Fedora-18-Alpha-TC5-x86_64-Live-KDE.iso

How reproducible:
always

Steps to Reproduce:
1. Run live-kde
2. log in as liveuser
3. try to run installation (from terminal run /usr/bin/liveinst)
  
Actual results:
segfault

Expected results:
anaconda starts

Additional info:
I propose this bug as an alpha blocker. The related criterion is:
'The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods'
Comment 1 Petr Schindler 2012-09-04 05:33:21 EDT
Created attachment 609608 [details]
liveinst.log
Comment 2 Lukáš Tinkl 2012-09-04 06:00:04 EDT
[11:47] <ltinkl> jreznik: /usr/lib64/gtk-3.0/3.0.0/theming-engines/liboxygen-gtk.so
[11:47] <ltinkl> and then (anaconda:3048): Gtk-WARNING **: Overriding tab label for notebook
[11:47] <ltinkl> my humble guess


Disabling oxygen-gtk would be an easy& fast fix
Comment 3 Kamil Páral 2012-09-04 08:58:16 EDT
Please note this only happens if you boot from USB (created from ISO using dd). If you boot from DVD, anaconda starts OK. Tested both architectures on several different machines.

Petr, in the original report, also used USB to boot.
Comment 4 Jaroslav Reznik 2012-09-04 09:16:45 EDT
On bare metal, booted with USB - it takes a long time to start and it's dual boot system and nfsresize eats 100% cpu all the time (so probably another bug? but similar symptoms, 100% cpu, maybe it overrides the original one)...
Comment 5 Kamil Páral 2012-09-04 10:33:09 EDT
(In reply to comment #4)
Unless you receive similar traceback to attachment 609608 [details], it's a different bug.
Comment 6 Kevin Kofler 2012-09-04 11:26:17 EDT
So this crashes inside libparted, I don't think KDE or oxygen-gtk have anything to do with this.
Comment 7 Brian Lane 2012-09-04 12:45:33 EDT
I can reproduce this with 'sudo parted /dev/sdf p' and selecting Ignore when it complains about the block size mismatch. Tested with nightly F18 iso and TC3 netboot.iso
Comment 8 Brian Lane 2012-09-04 19:43:51 EDT

*** This bug has been marked as a duplicate of bug 835601 ***

Note You need to log in before you can comment on or make changes to this bug.