Bug 854171 - dracut no longer displays progress of downloading files
dracut no longer displays progress of downloading files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 05:01 EDT by Kamil Páral
Modified: 2012-09-10 09:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 05:41:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-09-04 05:01:00 EDT
Description of problem:
If I use anaconda with inst.repo=http://, the progress of downloading stage2 image is no longer shown. It just waits and waits and waits and bam - prints out the statistics. That is very unfriendly. It used to work.

Version-Release number of selected component (if applicable):
Fedora 18 Alpha TC5

How reproducible:
always
Comment 1 Harald Hoyer 2012-09-06 05:41:45 EDT
This was removed, because the progress output of "curl" was buggy and significantly slowed down the download and/or cluttered serial consoles. Sorry.
Comment 2 Harald Hoyer 2012-09-06 05:44:31 EDT
See bug 817301 and bug 814713
Comment 3 Kamil Páral 2012-09-06 09:28:12 EDT
I see. OTOH, if the download takes 5 minutes, the user might be certain it is stuck, because completely nothing is printed out.

Could you please at least print out "Downloading file foo..." ?

Is it technically possible to at least print out a dot/percentage number every ten seconds, so that it is clear it is not dead?
Comment 4 Kamil Páral 2012-09-10 09:47:20 EDT
I found out the progress _is_ printed out, every circa 25 seconds. The output is not exactly easy to read, but that doesn't matter so much. So I take back the report, all is fine, thanks.

Note You need to log in before you can comment on or make changes to this bug.