Bug 854180 - inst.repo=nfs doesn't work
inst.repo=nfs doesn't work
Status: CLOSED DUPLICATE of bug 855170
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Betappc
  Show dependency treegraph
 
Reported: 2012-09-04 05:13 EDT by Kamil Páral
Modified: 2013-01-10 01:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 19:38:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-09-04 05:13:03 EDT
Description of problem:
If I boot anaconda using vmlinuz+initrd with this argument:

inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/18-Alpha-TC5/Fedora/x86_64/os/

I see this message:

dracut-initqueue[290]: mount.nfs: Protocol not supported
dracut-initqueue[290]: Warning: Couldn't mount nfs:,nfsvers=3:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/18-Alpha-TC5/Fedora/x86_64/os/
dracut-initqueue[290]: Warning: no suitable images
dracut-initqueue[290]: Warning: Could not boot.

The NFS directory can be mounted on an ordinary machine, but dracut doesn't seem to support it.

Version-Release number of selected component (if applicable):
F18 Alpha TC5

How reproducible:
always
Comment 1 Kamil Páral 2012-09-04 05:14:44 EDT
Proposing as Beta blocker:
" It must be possible to install by booting the installation kernel directly, including via PXE, and correctly specifying a remote source for the installer itself, using whichever protocols are required to work for package retrieval at the current phase (Alpha, Beta, Final). This must work if the remote source is not a complete repository but contains only the files necessary for the installer itself to run. "
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 2 Harald Hoyer 2012-09-06 05:49:16 EDT
dracut works very well with nfs3 and nfs4. It's probably anaconda which has faulty scripts here.
Comment 3 Paul Franklin (RHlists) 2012-09-06 10:23:05 EDT
I have a similar problem but don't know enough about anaconda
and so forth to know if is exactly the same one as you had:
https://bugzilla.redhat.com/show_bug.cgi?id=853508
Comment 4 Jesse Keating 2012-09-06 19:38:18 EDT

*** This bug has been marked as a duplicate of bug 855170 ***

Note You need to log in before you can comment on or make changes to this bug.