Bug 854183 - fence_xvm does not respect delay parameter in cluster.conf
fence_xvm does not respect delay parameter in cluster.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.9
Unspecified Unspecified
medium Severity high
: rc
: 5.10
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks: 928849
  Show dependency treegraph
 
Reported: 2012-09-04 05:23 EDT by michal novacek
Modified: 2013-09-30 18:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: cman-2.0.115-110.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 18:06:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/cluster/cluster.conf (947 bytes, text/plain)
2012-09-04 05:23 EDT, michal novacek
no flags Details

  None (edit)
Description michal novacek 2012-09-04 05:23:15 EDT
Created attachment 609605 [details]
/etc/cluster/cluster.conf

Description of problem:
When there is delay=15 added into <device> node in cluster.conf it is ignored
by /sbin/fence_node. fence_node command should first wait $delay seconds before
trying to send fence_command which it does not at the moment.

Version-Release number of selected component (if applicable):
RHEL-5.9, cman-2.0.115-106.el5

How reproducible: always.

Steps to Reproduce:
1. have cluster of three virtual machinech
2. on one of the nodes create/modify /etc/cluster/cluster.conf similar to the
one attached in which each <device> will have delay=15 attribute.
3. use "ccs_tool update /etc/cluster/cluster.conf" to distribute this config to
all nodes on the cluster.
4. on one of the nodes time fencing other node in the cluster
  
Actual results:
takes about two seconds.

Expected results:
should first wait $delay seconds and then try to fence the node which should
take more than 15 seconds.

Additional info:
partly related: https://bugzilla.redhat.com/show_bug.cgi?id=804170
Comment 5 errata-xmlrpc 2013-09-30 18:06:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1304.html

Note You need to log in before you can comment on or make changes to this bug.