Bug 85420 - Installation/update 8.0.93 -> 8.0.94-2 on Dell 8250 with ATI Radeon 9700 impossible!
Installation/update 8.0.93 -> 8.0.94-2 on Dell 8250 with ATI Radeon 9700 impo...
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-01 17:26 EST by Hardy Mayer
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-26 21:36:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hardy Mayer 2003-03-01 17:26:10 EST
Description of problem:
I ran into a number of problems installing 8.0.93 on a brand-new
Dell 8250, 2.4 GHz P4, 256 MB PC1066 RDRAM, 128 MB ATI Radeon 9700 TX
AGP card, 1702 FP digital display.
1. On bootup from Phoebe disk 1, the ps/2 keyboard and mouse are 
not recognized (you can't even reboot with Ctr-Alt-Delete!)
After a number of trials and errors I disabled USB in the BIOS and 
the boot and installation proceeded smoothly. X works fine with 
XFree86-4.2.99.3-20030115.0

This problem -- clearly associated with the new Intel 850 motherboard and/or the
Dell A01 BIOS needs urgent addressing, since there are many 8250 out in our and
other Universiies and people are complaining that they have to use Windows XP
(with VMWare  or Cygwin for real work). 

2. After resetting the USB in the BIOS, the system still did not 
recognize any of my USB devices (printer, scanner, storage). 
An upgrade to  kernel-2.4.20-2.24 fixed the USB problems, but so far sound still
does not work (from CDrecord, xmms, etc).  The speaker responds to 
system sounds from xemacs, xcdroast, etc.)  The sound card is
an on-baord integrated SoundMax card and uses modules 
i810_audio             27720   1 (autoclean)
ac97_codec             13608   0 (autoclean) [i810_audio]
soundcore               6404   2 (autoclean) [i810_audio]

3. Since the list of 8.0.93 software also contained a newer version 
of XFree86 
XFree86-4.2.99.3-20030118.3.i386.rpm
made X unusable: X complained about a missing Device entry (e.g., 
PCI:1.0.1) in XF86Config, which was created by the original installation. 
Ditto, running Xtest; both essentially switched off the monitor.
4. I had to do a clean reinstall of 8.0.93 (3 hours!), and ugrade the kernel to
 kernel-2.4.20-2.24 brought the system back to the previous state, with
usb devices recognized (I had to hack the /etc/modules.conf file for this). 


5. I had hoped that these problems will be solved in 8.0.94,  but alas, 
a) the keyboard mous problem is still there, and
b) after recognizing the Vidocard and monitor on bootup, 
the installation "dies" for lack of a display -- the Xtest (or whatever is used 
to access the card simply switches the video off). 
I did not proceed to a text-based upgrade, since I knew what's coming. 

BTW I had no problemd upgrading 8.0->8.0.93->8.0.94-2 
on my older box, with an Asus P2SB Motherboard, 7570 MHz P3, Matrox G200 vidoe

Version-Release number of selected component (if applicable):
 8.0.93 and 8.0.94-2 

How reproducible:
At least 4 times!

Steps to Reproduce:
1.Try installing 8.0.94 on a Dell 8250 with the Radeon 9700 TX card!
2. The keyboard/mouse/usb bug also exists on the 8.0 disk.
3.
    
Actual results:
I had to settle for the less than perfect 8.0.93 installation
and am still trying to figure out why the sound is not working poperly
(permissions on /dev/dsp?).
Why has redhat not adopte the devfs which worked fine for me on a custom built
kernel? 

Expected results:
Perfect digital 2D graphics from the expensive videocard and monitor. 
At least miserable sound output from CDPlayer. 
vlc does not work -- it dif in previous versions of RH Linux. 


Additional info:
Please look into the newsgroup discussions and also the Dell-Linux users group
discussions for similar experiences.
Comment 1 Hardy Mayer 2003-03-01 17:39:37 EST
Sorry for a few  typos; I'm just getting used to the Dell keyboard.
Comment 2 Mike Chambers 2003-03-01 23:11:37 EST
Were these clean installs of Phoebe or upgrades?  If upgrades, you need to try
do install them as new fresh installs to see if the problem still persists.

If they both were clean, it would be helpful if you can do a install (via text
mode or whatever), upgrading to at least the latest rawhide kernel and XFree
packages (or even Mike's Xfree-4.3.0-x from his ftp site
(ftp://people.redhat.com/mharris/testing/unstable/XFree86 (when he gets them
uploaded again lol)).

Then run redhat-config-xfree86 to see how everything works.  If it still doesn't
work, attach your XFree config file and log file so it can be looked into
further, and give your version number of your kernel and XFree package to make
sure we are all on the same page.
Comment 3 Hardy Mayer 2003-03-02 00:33:51 EST
8.0.93 was installed 3 times; the last and first, which worked were 
clean installs with new partitions/reformatted system partitions. 
The second one was an attempted update, after updating the kernel and 
XFree86 to the later version (from 8.0.94) which broke the XFree86. 

Since I have a working system on a one-week-old machine, I prefer not to waste
time on experimental XF86-es.  
On my old (P3) machine I had no problems with customized kernels (they worked
better than the modularized ones coming from RedHat, particularly with 
my scsi/ide mixed disk config. 

A clean install of 8.0.94-2 is impossible (since if I use text-mode I am almost
guaranteed tha X will never work;  the release notes mumble something about
Xtest being abandoned, etc.).  And to boot (in both senses of the word) the the
keyboard and mouse are not even recognized if USB is active!
 
The Dell machine should have worked right ot of the Box, if RedHat and
XFree86.org has put the emphasis on the system, rather than the awful new
Windows-like look of gnome (I disabled nautilus to keep a clean desktop, without
windows-like  popups).  I wish I could get sawfish to work as my wm, since it is
the only one written in a lisp-dialect which is humanlyu understandable.

I hope that by the time the "official" 8.1 with full XFree86-4.3 and a working
redhat-config-xfree86 (without all sorts of python-inconsistencies) are out
I will get a consistent system for the Dell 8250.   Had I known how things are,
I could have saved the University $ 500 by getting a 4250 with an NVidia
graphics card.  I have been a Linux user since 1995, and have not had this kind
of frustrations since hacking XF86Config on  an IBM Thinkpad 760.
Comment 4 Mike A. Harris 2003-03-14 18:50:44 EST
I'm not quite sure why you dumped all of your rants into one bug report.
Bugzilla bug reports _must_ be one single isolated issue per bug report.
This report is a mishmash of ranting, with no one single issue being reported,
and not enough useful information to really do anything.

Please file new bug reports with one single isolated issue per bug report
and provide enough relevant details in each report to make the information
useful to an engineer trying to investigate each matter please.

It also helps greatly if you can relax the ranting, as it makes two way
communication much easier, and greatly increases the chances that a
solution can be found, as positive communication allows more to transpire
than does negative communication.
Comment 5 Mike A. Harris 2003-03-14 18:52:14 EST
>Why has redhat not adopte the devfs which worked fine for me on a
>custom built kernel? 

Because it is insecure and unsupportable crap basically.  But I wont go
into that.
Comment 6 Hardy Mayer 2003-03-22 16:43:59 EST
1. Workaround for the unrecognized keyboard when booting from Phoebe disk 1:
start linux with the option:
linux nousb. 

This should be documented in the release notes.
Still no luck with sound from the cd-player (even with various
kernel-customizations). 
Comment 7 Pascal Rullier 2003-03-23 11:08:30 EST
I had the same trouble when i wanted to install RedHat8.0. I have solved the
problem without disable usb by adding to the kernel parameter hdc=ide-scsi
during install.
For the ATI Radeon 9700 TX, i installed third party found on ATI web site.
(fglrx-glc22-4.2.0-2.5.1.i586.rpm)
XFree86 works fine in 1280x1024x16
Comment 8 Hardy Mayer 2003-03-26 21:36:46 EST
Re the sound problem. A simple workaround (although this is not a RedHat problem
per se, it might be worth mentioning in the release notes). 
It turns out that on the Dell 8250 (and possibly other Dell machines) with
on-board audio the CD-ROM drive is not connected to the analog inputs of the DSP. 
Apparently Windows XP is using digital audio dirrectly toi the motherboard,
whereas the various Linux CD-players seem to require analog connections. 

The simple workaround is a cable between the CD-drive(s) and the onboard audio
analog input!

Note You need to log in before you can comment on or make changes to this bug.