Bug 854249 - cglib is missing OSGi metadata (which prevents mockito from resolving properly)
cglib is missing OSGi metadata (which prevents mockito from resolving properly)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cglib (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 09:34 EDT by Severin Gehwolf
Modified: 2012-09-18 10:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 10:47:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (1.78 KB, patch)
2012-09-04 09:34 EDT, Severin Gehwolf
no flags Details | Diff

  None (edit)
Description Severin Gehwolf 2012-09-04 09:34:37 EDT
Created attachment 609687 [details]
Proposed fix

Mockito imports classes from net.sf.cglib.proxy. In order for the Import-Package statement to be satisfied for it, cglib needs to export packages (and have OSGi metadata in the first place).

I'm attaching a patch with a proposed fix.
Comment 1 Severin Gehwolf 2012-09-04 09:35:44 EDT
If you prefer, you can give commit privileges to me and I'll push the fix myself. Thoughts?

https://admin.fedoraproject.org/pkgdb/acls/name/cglib

Thanks!
Comment 2 Severin Gehwolf 2012-09-17 05:00:19 EDT
Any thoughts?
Comment 3 Lubomir Rintel 2012-09-17 07:33:17 EDT
Thanks a lot!

I've approved your ACLs and remove myself from package, since I'm no longer willing to deal with Java stuff. I'd be thankful if you could take the package.

Reassigning the issue to you.
Comment 4 Severin Gehwolf 2012-09-17 07:53:55 EDT
Thanks for responding, Lubomir!
Comment 5 Severin Gehwolf 2012-09-18 10:47:59 EDT
Fixed with:
http://koji.fedoraproject.org/koji/buildinfo?buildID=354751

Note You need to log in before you can comment on or make changes to this bug.