Bug 85426 - X server resets when working in Virtual Terminal 1
Summary: X server resets when working in Virtual Terminal 1
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-02 07:28 UTC by Gunter Zielke
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 22:20:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gunter Zielke 2003-03-02 07:28:41 UTC
Description of problem:
I have a X session running on virtual terminal 7 and am logged in as a user.
Now I want to do some text based work as root without disturbing the X session.

With Ctrl-Alt-F1 I switch to another virtual terminal and login in as root.
Moments later the X server is restarted and I am presented with a graphical 
login screen. Switching back to virtual terminal 1 shows me that I am still 
logged in as root. as long as I do not log in as a user on virtual terminal 7 
I can work as root in VT 1, but when I log in on VT 7 and then go back to VT 1 

and issue some commands as root (or any other user logged in in text mode) the 

the X reset happens again.

Version-Release number of selected component (if applicable):


How reproducible:
always - at least on my system

Steps to Reproduce:
1. login graphically as a user on virtual terminal (VT) 7
2. switch to VT1 and log in as a user
3. type some command line command like ls
    
Actual results:
X server is restarted, display is switched to VT7 and I have to 
log in again - old session is lost

Expected results:
to be able to continue using VT1 without disturbing session on VT 7

Additional info:

Comment 1 Mike A. Harris 2003-03-03 07:35:54 UTC
I don't have any idea what video hardware you're using, or what driver, etc.

Please attach your X server config file and log file text/plain as individual
uncompressed separate attachments using the link below.

Comment 2 Gunter Zielke 2003-03-11 22:56:59 UTC
The behavior was noticed with an off-brand graphics card (sis) with the vesa 
driver in 1600x1200x16bit mode.
in the meantime I have changed to a nVidia card and don't see (and this can 
not reproduce) the behavior.
thanks,
Gunter

Comment 3 Mike A. Harris 2004-09-28 22:20:08 UTC
Ok, thanks for the update.  If you experience the problem again in
Fedora Core 2 or later, please include the files requested in comment
#1 above, as file attachments and reopen and we will review the
issue again.

Thanks.


Setting status to "CURRENTRELEASE", assuming the problem is fixed
in X.Org X11 6.7.0 or later.


Note You need to log in before you can comment on or make changes to this bug.